Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [SLE] date / time problems
  • From: Patrick Shanahan <ptilopteri@xxxxxxxxx>
  • Date: Mon, 3 Apr 2006 12:35:21 -0400
  • Message-id: <20060403163521.GB3878@xxxxxxxxxxxxxxx>
* John Moore <database1@xxxxxxxxxxxxxxxxxxxxxxxxxx> [04-03-06 12:05]:
> I have SuSE 10.0 running at work and at home and it works great. Except
> I cannot -- either through the applet at the top of the screen or
> through YAST -- get SuSE to do the time right. I set the correct time
> and date and click Apply it doesn't stick. I even tried rebooting --
> something you usually don't have to do -- but it made no difference.
> Sigh. Currently my time is correct but the date reads March 4 (should
> be April 3).
>
> I run Gnome so I am thinking this could be a Gnome bug. Any
> suggestions?

Try from the command line (as root):
date -s MMDDhhmm
-s set date-time
MM month
DD day
hh hour
mm minutes

note: month, day, hour and minutes need to be two digits each

date -s 04031233

or more extensive
Usage: date [OPTION]... [+FORMAT]
or: date [-u|--utc|--universal] [MMDDhhmm[[CC]YY][.ss]]

date -s 040312332006.33

man date

If this does not solve your problem, please give your observations and
we will try again.
--
Patrick Shanahan Registered Linux User #207535
http://wahoo.no-ip.org @ http://counter.li.org
HOG # US1244711 Photo Album: http://wahoo.no-ip.org/gallery2

< Previous Next >
References