Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [SLE] cron not recognizing changes to /etc/cron.d files [SOLVED]
  • From: "Carlos E. R." <robin1.listas@xxxxxxxxxx>
  • Date: Sun, 9 Apr 2006 01:09:12 +0200 (CEST)
  • Message-id: <Pine.LNX.4.61.0604090101070.2032@xxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


The Friday 2006-04-07 at 19:39 -0800, Scott Leighton wrote:

> > Interesting. Compare the mcedit versions (rpm -q mc) (mcedit --version)
>
> I did, they are identical on both boxes.

Perhaps the 64 bit version was compiled with a diferent option.

> ...
> Also tried diff'ing the various config files in /usr/share/mc and
> in ~/.mc and couldn't find anything different that seemed pertinent.

Anything about creating a backup file while editing?


> On the 64 bit box, mcedit creates a softlink in the current
> directory for the file being edited, that apparently causes the
> directory timestamp to update. On the 32 bit box, no softlink
> is created and I have no idea at all why they act differently.

If it doesn't create a softlink it means it makes no backup of the file,
but changes it in place. That method does not alter the directory, it does
not create nor delete files. I think only the inode might change.

> I've resigned myself to simply doing a rccron restart.

Simply edit it again wit a diferent editor, like joe (aka jstar aka jmacs
aka rjoe aka jpico), and save.

- --
Cheers,
Carlos Robinson
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
Comment: Made with pgp4pine 1.76

iD8DBQFEOEKitTMYHG2NR9URAmMNAJ9obOKsVLHhWlxil2XXHQ0SVKxVngCdF9u8
qfZMm7TGVEQFzg+pymL5lZo=
=P2rI
-----END PGP SIGNATURE-----


< Previous Next >
Follow Ups