Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [SLE] cron not recognizing changes to /etc/cron.d files [SOLVED]
  • From: Scott Leighton <helphand@xxxxxxxxxxx>
  • Date: Sat, 8 Apr 2006 15:24:24 -0800
  • Message-id: <200604081624.25858.helphand@xxxxxxxxxxx>
On Saturday 08 April 2006 4:09 pm, Carlos E. R. wrote:
> The Friday 2006-04-07 at 19:39 -0800, Scott Leighton wrote:
> > > Interesting. Compare the mcedit versions (rpm -q mc) (mcedit --version)
> >
> > I did, they are identical on both boxes.
>
> Perhaps the 64 bit version was compiled with a diferent option.
>
> > ...
> > Also tried diff'ing the various config files in /usr/share/mc and
> > in ~/.mc and couldn't find anything different that seemed pertinent.
>
> Anything about creating a backup file while editing?
>

There's a setting, 'editor_option_save_mode', but it is set to 0
on both systems.

> > On the 64 bit box, mcedit creates a softlink in the current
> > directory for the file being edited, that apparently causes the
> > directory timestamp to update. On the 32 bit box, no softlink
> > is created and I have no idea at all why they act differently.
>
> If it doesn't create a softlink it means it makes no backup of the file,
> but changes it in place. That method does not alter the directory, it does
> not create nor delete files. I think only the inode might change.
>
> > I've resigned myself to simply doing a rccron restart.
>
> Simply edit it again wit a diferent editor, like joe (aka jstar aka jmacs
> aka rjoe aka jpico), and save.
>

I'm way too old and set in my ways to change my habits ;) My
fingers automatically type mcedit when I'm on the commandline,
no thinking involved at all.

Scott


--
Aegroto, dum anima est, spes esse dicitur
POPFile, the OpenSource EMail Classifier http://popfile.sourceforge.net/
Linux 2.6.11.4-21.11-default x86_64
SuSE Linux 9.3 (x86-64)

< Previous Next >