Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Installing the CERN library ... please advice
  • From: Maura Edeweiss Monville <memonvil@xxxxxxxxxxxxxxxx>
  • Date: Fri, 14 Apr 2006 12:10:25 -0500 (CDT)
  • Message-id: <Pine.GSO.4.58.0604141205520.9411@xxxxxxxxxxxxxxxxxxxxx>
I downloaded the CERN library src files from the public website:
http://wwwasd.web.cern.ch/wwwasd/cernlib/download/2005_source/tar/

you can get here by clicking on "latest version" on the web page:
http://cernlib.web.cern.ch/cernlib/install/install.html

Then I ran the script that is displayed by clicking on "shell script" on
the same web page
http://cernlib.web.cern.ch/cernlib/install/install.html

It created the structure. I placed some "echo" statements in the script so
as I could follow the logic as described.
But the generated log file at
/home/mauede/Download/CERNLIB-Dir/2005/build/log
contains 3 files (I'll send attachment "Log-After-1st-Script.tar.gz" in
a separate e-mail bearing the same subject).
Two of them show a lot of errors that I have no idea how to fix.
I have NOT written such a code myself.
So such a script failed to create the library. In fact the following
directory:
/home/mauede/Download/CERNLIB-Dir/2005/lib
is empty !
One concern that I have is that IF the CERN library is for 32-bit
architecture then I probably need to change some
flags/options (which one ?) in the generated Makefiles (which one ?)
as my laptop is 64-bit architecture.

Since I ran the CERN library installation script without sourcing
~/bin/gcc-4.1 (I installed gcc-4.1 recently) the standard gcc-3.5
(that came with SuSE 9.3) has been invoked (so what ?)
...

Following the guidelines on the CERN web page:
http://cernlib.web.cern.ch/cernlib/install/install.html
I ran he second script that is displayed by clicking on "simple script".
As a result I got some more error files in the
/home/mauede/Download/CERNLIB-Dir/2005/build/log
another 3 error files (I'll send the attachment
"Log-After-2nd-Script.tar.gz" in a separate e-mail bearing the same
subject)

I forgot the intermedate step in-between the two scripts that is to build
Pawlib as described by clicking on "here" at the same web page
http://cernlib.web.cern.ch/cernlib/install/install.html
Neverless I think that is not so critical given the number of unresolved
symbols etc... at the moment.
I cannot figure out IF all these errors I got are due to using different
building tools versions or to the fact that my laptop is 64-bit whereas
the CERN library was built on a 32-bit machine.
Or the flags and options in the automatically generated Makefiles are not
corrects for my system ... I'm totally lost here !
I think there is no point at proceeding further without getting the lib
created first.

I would greatly appreciate some suggestion about that huge list of
errors and how to address this problem.
Sorry I'm a physicist with poor computer science backgroung so I struggle
all the time with h/w and s/w related issues ...

Thank you in advance for all your help,

--
Maura E.M

< Previous Next >
Follow Ups