Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [SLE] updating to PHP5
  • From: "Ricardo Rodríguez - XEN (rrodriguez@xxxxxxx)" <rrodriguez@xxxxxxx>
  • Date: Wed, 19 Apr 2006 07:56:22 +0200
  • Message-id: <20060419T075622Z_C5AC00020000@xxxxxxx>
>>> Andrei Verovski (aka MacGuru)andreil1@xxxxxxxxxxx> 17/4/2006 11:41 >>
>cd /opt/lampp (no need 3 steps)
>./lampp start (preceeding dot before slash)

Thanks again, Andrei.

Xampp up and running over here in a SuSE 10.1beta8 box and SuSE 9.0 one. Both of them running PHP 5.1.2. The PHP based applications run fine. And by editing the httpd.conf and some SSL related conf concerned files the default Apache instance is running in a different IP than Xampp is using. Great.

The only problem is that the Xampp start scripts seems to check for an Apache daemon running on any port or IP, thus if the default Apache is running, it fails to start even though it will do that in a differente IP address. The solution is to start Xampp first, then the default instance. But I'm not able to figure out how to automatically do that.

Please, could you tell me what scripts are implied in the start up process? How could I tell Linux that it must starts Xampp first, then the default Apache instance?

To modify the Lampp start up script to increase granularity while testing for availables IPs/ports is completely out of my scope at the moment!

Thanks for your help,

Ricardo


--
Ricardo Rodríguez
XEN, Resources Management


< Previous Next >