Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
RE: [SLE] The "cp" command is skipping files/dirs over nfs
  • From: "James D. Parra" <Jamesp@xxxxxxxxxxxxxxxx>
  • Date: Wed, 19 Apr 2006 09:59:15 -0700
  • Message-id: <531F1E080638384C9623B00D71AA546D09ED9D@xxxxxxxxxxxxxxxxxxxxxxxxx>
Hello,

Thank you for the helpful instructions.

The progress output currently goes to the display, but is there a way to
direct the progress output to a file for future review, as well as to the
display? The problem is that I can only scull up so far on the monitor and
I want to see which files were skipped early on during the copy.

Many thanks.

James

-----Original Message-----
From: Lawrence Bowie [mailto:thesource@xxxxxxxxxxx]
Sent: Friday, October 14, 2005 7:23 PM
To: James D. Parra
Cc: Suse-Linux-E (E-mail)
Subject: Re: [SLE] The "cp" command is skipping files/dirs over nfs


Descend into the directory and execute ..

(cd /mnt/oldserver && find . -depth | cpio -dvmp /usr/cvsroot)


LDB

James D. Parra wrote:
>> find /dir -depth | cpio -dvmp /new_dir
>
>>to recursively copy objects because it lets me know if something was NOT
>>copied properly. I do not like cp either on UNIX or Linux because I run
>>into issues like you have described every now and then.
>
> Thank you for the tip. I tried it, but I noticed something interesting;
>
> If I use, #find /mnt/oldserver/* -depth | cpio -dvmp /usr/cvsroot/
>
> I get a directory /usr/cvsroot/mnt/oldserver/, when what I need is to copy
> the contents of /mnt/oldserver to /usr/cvsroot/, without the path, just
the
> identical contents.
>
> How can I modify your command to accomplish this?
>
> Thanks again,
>
> ~James
>

< Previous Next >
Follow Ups