Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [SLE] SuSe and issues with their kernel's.
  • From: Brad Dameron <brad@xxxxxxxxxx>
  • Date: Thu, 20 Apr 2006 17:44:07 -0700
  • Message-id: <1145580247.19598.13.camel@xxxxxxxxxxxxxxxxxxxxxxxxx>
On Thu, 2006-04-20 at 21:50 +0200, Per Jessen wrote:
> Brad Dameron wrote:
>
> >> You don't rebuild your initrd?? "mk_initrd"?
> >>
> > The make install actually does a mkinitrd for you.
>
> Really? OK, I didn't know that. If your initrd is up-to-date, I cannot
> explain why you are having problems. I've sofar always rebuilt my
> initrd separately.
>
> >> AFAIK, SUSE is working towards a mostly-vanilla kernel, and have
> >> already reduced the number of extra patches considerably.
> >
> > What is interesting is several apps we run don't like to compile
> > against SuSe's kernel. However work perfectly against the vanilla one.
>
> Are these just applications or actually kernel extensions, such as GFS?
> For the latter, SUSEs extra "-Werror-implicit-function-declaration"
> could be causing a problem. And in this case, cluster-1.02.00 most
> certainly does not compile perfectly against the 2.6.16.9 vanilla
> kernel.
>
> >>> Or if anyone is using GFS on SuSe let me know what you did.
> >>
> >> I have only looked at it so far, but I find it very difficult to
> >> accept that SUSEs kernel modifications would prevent GFS from
> >> building.
> >
> > Actually they do. I tried many version's of GFS against several
> > different SuSe kernel's. No go. They would error out in different
> > locations each time.
>
> Apart from the already mentioned
> "-Werror-implicit-function-declaration", _nothing_ in the SUSE
> 2.6.16-20 kernel prevented cluster-1.02.00 from building. But please
> do prove me wrong. Why haven't you reported this to SUSE/Novell?
>

I tried to compile it against the 2.6.16-20 kernel and had problems as
well. I installed the source rpm, did a make cloneconfig in the
directory, did a make. Then went to the cluster package did
a ./configure --kernel_src=/usr/src/linux-2.6.16-20, then a make
install. It got down to dio.c and failed. I will post the exact error
tomorrow. I would love to be able to do a simple SuSe 10 install and be
able to compile GFS against the installed kernel.


> > But I won't be picky. Thanks for the comment.
>
> One final comment then - to me, you were a little to quick in dishing
> out the blame here. You don't seem to have spent much time
> debugging/diagnosing the problem, yet you feel able to get up on your
> soapbox and point the finger. Maybe I'm a little sensitive, but it's
> not the really the right approach IMHO.

Actually I spent quite a lot of time trying to get this to work. And
some of the things SuSe is doing had finally brought me to a boiling
point. Like their lack of server side rpm updates. They seem to be
focusing on mainly desktop updates. Yes I should go with enterprise
version. But I checked that out as well and some server side packages
are still back from early 2005. I am referring to things like LVM2,
device-mapper for starters. Maybe I should not have posted it like this.
But I was very flustered.

Brad Dameron
SeaTab Software
www.seatab.com




< Previous Next >