Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Sierra aircard 860, udev and /dev/modem problem (long)
  • From: Adolph Weidanz <timetopaws@xxxxxxxxx>
  • Date: Sat, 22 Apr 2006 14:32:00 -0400
  • Message-id: <444A76A0.9080000@xxxxxxxxx>
Hey all...

I decided to try this card and the HSDPA service from cingular out. Of
the cards they offered the only one that had anything I could find about
working with Linux was the Sierra. I thought I had it made as they even
had a howto and drivers, although they did say that it was unsupported
and provided as a 'courtesy'. I only have about 2 weeks left to play
with this, before I send it back so I wont get charged for it.

The problem first and then I'll explain what I've tried. The card is a
Sierra aircard 860 PCMCIA, that provides 3G, GPRS, EDGE and HSDPA. I
plugged in the card, currently using slot 0, although I have tried slot1
as well. I found something simalar on the net for SUSE 10.0, that said
to just use Yast, so I configured it with Yast (Modem), which uses
/dev/modem as the Modem Device. I also tried using /dev/ttyS0 (I'll talk
more on this later) which is present in /dev. I try to access it and
nothing happens (log snippets are below). There does not seem to be a
/dev/modem created by udev. After trying through Yast, I also tried to
follow the howto on sierra's website, which has a driver and has the
lines (see bottom of logs) added to /etc/pcmcia/config.opts, but it
seemed to make no difference:

I am using KDE 3.5.2 Level a, 2.6.16-rc1-git3-20060126153156-default and
SuSE Meta pppd (smpppd-ifcfg), Version 1.59 on linux. This is on a
Gateway 600YG2 laptop

The card seems to be seen by the system. When I did a hardware info
through Yast:
34: udi = '/org/freedesktop/Hal/devices/pcmcia_402_1808'
info.udi = '/org/freedesktop/Hal/devices/pcmcia_402_1808'
linux.subsystem = 'pcmcia'
linux.hotplug_type = 1 (0x1)
info.product = 'AC860'
info.vendor = 'Sierra Wireless'
pcmcia.manfid2 = 1808 (0x710)
pcmcia.manfid1 = 402 (0x192)
pcmcia.function = 'network'
pcmcia.productid_4 = 'R1'
pcmcia.productid_3 = '3G Network Adapter'
pcmcia.productid_2 = 'AC860'
pcmcia.productid_1 = 'Sierra Wireless'
pcmcia.socket_number = 0 (0x0)
info.parent = '/org/freedesktop/Hal/devices/pci_104c_ac55_0'
info.bus = 'pcmcia'
linux.sysfs_path_device =
'/sys/devices/pci0000:00/0000:00:1e.0/0000:02:02.0/0.0'
linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1e.0/0000:02:02.0/0.0'


/etc/udev/rules.d/50-pcmcia.rules has:
SUBSYSTEM=="pcmcia_socket", ACTION=="add", RUN+="/sbin/hwup
pcmcia_socket-devpath-%p -o hotplug"
SUBSYSTEM=="pcmcia", ACTION=="add", RUN+="/sbin/hwup pcmcia-devpath-%p
-o hotplug"
LABEL="after_pcmcia"

when the card is plugged in once the system is restarted, dmesg says:
pccard: PCMCIA card inserted into slot 0
cs: memory probe 0xe8200000-0xe89fffff: excluding 0xe8200000-0xe82fffff
pcmcia: registering new device pcmcia0.0

smpppd log ifcfg-modem0.log says
SuSE Meta pppd (smpppd-ifcfg), Version 1.59 on linux.
Status is: disconnected
trying to connect to smpppd
connect to smpppd
Status is: disconnected
Status is: connecting
Status is: disconnected
pppd[0] died: pppd options error (exit code 2)
terminating

Man pppd says exit code "2 An error was detected in processing the
options given, such as two mutually exclusive options being used."

/var/log/messages says:
Apr 20 20:34:02 linux pppd[6499]: unrecognized option '/dev/modem'
Apr 20 20:36:53 linux pppd[6545]: unrecognized option '/dev/modem'
Yast has configured it as /dev/modem, however I don't find it listed
under /dev.

I've looked at man pppd with no luck, then I went to smpppd which is
SUSEs SuSE Meta PPP Daemon, which is what seems to exiting with an error
code of 2 (according to the log). The smppd.conf file was unchanged, the
man file says Use rcsmpppd instead... I typed in rcsmppd start got
'sarting smpppd' but it didn't seem to give me anything. I believe that
I am getting this because it is not finding /dev/modem


ifcfg-modem0 file:
BOOTPROTO='none'
DIALCOMMAND='ATDT'
DIALPREFIX=''
DIALPREFIXREGEX=''
INIT1='at+cgdcont=1,"IP","isp.cingular"'
INIT2=''
INIT3=''
INIT8='ATM0'
INIT9='ATX3'
MODEM_DEVICE='/dev/modem'
NAME='Modem'
PPPD_OPTIONS=''
PROVIDER='provider0'
SPEED='57600'
STARTMODE='manual'
UNIQUE=''
USERCONTROL='yes'


network/providers/provider0 says:

ASKPASSWORD='no'
AUTODNS='yes'
DEFAULTROUTE='yes'
DEMAND='no'
DSLSUPPORTED='no'
IDLETIME='300'
IPADDR=''
ISDNSUPPORTED='no'
MODEMSUPPORTED='yes'
MODIFYDNS='yes'
MODIFYIP='yes'
PASSWORD='*********'
PHONE='*99#'
PROVIDER='isp.cingular'
REMOTE_IPADDR=''
STUPIDMODE='no'
USERNAME='ISP@xxxxxxxxxxxxxxxx'

/var/run/smpppd has the sockets for control and ifcfg-modem0

When I reconfigured to ask for the password, after I enter it I get a
socket created in /var/run/smpppd = it looked like wvdial-modem.conf
(Comes and goes really quicklly), but no connection. The says the same
as before

/etc/pcmcia/config.opts
card "Sierra Wireless AC860 3G Network Adapter"
manfid 0x0192,0x0710
cis "cis/SW_8xx_SER.dat"
bind "serial_cs"
I created the directory cis and placed the data file in it.
Trying this seems to have made no difference

Switching to /dev/ttyS0;
SuSE Meta pppd (smpppd-ifcfg), Version 1.59 on linux.
Status is: disconnected
trying to connect to smpppd
connect to smpppd
Status is: disconnected
Status is: connecting
pppd[0]: Plugin passwordfd.so loaded.
pppd[0]: --> WvDial: Internet dialer version 1.54.0
pppd[0]: --> Initializing modem.
pppd[0]: --> Sending: ATZ
pppd[0]: --> Sending: ATQ0
pppd[0]: --> Re-Sending: ATZ
pppd[0]: --> Modem not responding.
pppd[0]: Connect script failed
Status is: disconnected
pppd[0] died: Connect script failed (exit code 8)
terminating

I think it boils down to the creation of /dev/modem....
If there are any logs I've forgotten I'll be happy to send them on. I
really need to get this running, as I haven't had but intermittent
internet for six months and I'm suffering from withdrawals Thanks for
any help....

< Previous Next >
This Thread
  • No further messages