Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [SLE] Re: Wine problem
  • From: Michael W Cocke <cocke@xxxxxxxxxxxxxx>
  • Date: Mon, 24 Apr 2006 17:16:04 -0400
  • Message-id: <5ffq4210j108encmm6h26gomm62ccgqkcu@xxxxxxx>
On Mon, 24 Apr 2006 17:03:16 +0200, you wrote:

>Hi Michael et al...
>On Sunday 23 April 2006 19:44, Michael W Cocke wrote:
>> On Sun, 23 Apr 2006 10:59:01 +0200, you wrote:
>> >Hi all,
>> >
>> >I'm trying to get an old copy of MS publisher working with wine. But I get
>> >these errors. Could someone give me an idea what I'm missing?
>>
>> How old a version of publish? Publish 1 (or was it 2? - the first
>> shipped version) had major problems and used a completely different
>> internal architecture than all other MS apps.. That was the version
>> that MS bought from the original company and relabeled. There's no
>> way at all to make that version work in wine. It barely worked in
>> windows. Malloc faults resulted in a crash roughly hourly.
>>
>> Publish 98 can be made to work with wine, just force the emulation to
>> windows 95 (see the wine system.ini file).
>>
>> Publish XP should 'just work' - it always has here.
>
>I think its Publisher 1, I got it in 1993 for Windows 3.1. After I sent the
>first email I tried to run notepad and wine said that I did not have enough
>memory. I have 1gb so I think that I have something wrong with my config
>file. What do you think?
>


I think you have several different problems. First of all, that's the
version of publish that I never got to work in wine or in crossover
office. Badly written doesn't come close to describing that code, but
it will do until I think of more profanity.

As for the notepad problem... I think you need to re-read the wine
docs. What happens (roughly - anyone who wants to can explain in more
detail) is this; When you run a windows app thru wine it's sort of
recompiled to run as native linux code. Wine isn't an emulator, in
other words - so your configuration isn't really relevant. What MIGHT
have happened is that your wine install got hashed somehow. Try
reinstalling that. Another probability; windows notepad - or any
other base piece of windows - is quite likely to have ugly crud direct
from mickysoft in it to prevent exactly what you're trying to do -
make mickysoft code run in a non-mickysoft environment.

Mike-
--
If you're not confused, you're not trying hard enough.
--
Please note - Due to the intense volume of spam, we have installed
site-wide spam filters at catherders.com. If email from you bounces,
try non-HTML, non-encoded, non-attachments,


< Previous Next >