Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [opensuse-factory] RC1: xgl+compiz+nvidia-8756? all video players crash
  • From: J Sloan <joe@xxxxxxxxxx>
  • Date: Fri, 28 Apr 2006 15:19:01 -0700
  • Message-id: <445294D5.5080000@xxxxxxxxxx>
Silviu Marin-Caea wrote:
> On Apr 28, 2006 06:17 AM, J Sloan <joe@xxxxxxxxxx> wrote:
>
>> Hello all,
>>
>> What is the secret of getting xgl desktop with working video? I saw
>> the novell
>> demos so I know it's gotta be possible.
>>
>> I have a Dell GX270 with nvidia card, and it ran suse 10 flawlessly. I
>> did a
>> clean install of 10.1-RC1 since I wanted to see the xgl stuff in
>> action. I did
>> everything as defined in the "Novell cool solutions" article*, and the
>> rotating cube, transparency, and all the other compiz effects are
>> running as
>> advertised. Everything looks great. until I play a video. any video.
>> Playing a
>> realmedia file with realplayer, or an mpeg with xine or mplayer, gives
>> the
>> same result: the X server dies instantly the millisecond that I
>> attempt to
>> play the video.
>>
>> Is this a known issue? Surely I'm not the only one here who has tried
>> to view
>> a video on an xgl-enabled desktop?
>
> I'm replying to opensuse@ as well, please continue the thread there, if
> necessary.
>
> I didn't try with an nvidia card, I have Intel on-board video, but I get
> the same crash when trying to play video with the xv driver. It's
> because the Intel driver does not have yet the capabilities required.
> But the nvidia driver does.
>
> Make sure you have these options in /etc/sysconfig/displaymanager
>
> DISPLAYMANAGER_XGL_OPTS="-accel glx -accel xv"
>
> If -accel xv does not work for you, try -accel xv:pbuffer
>
> If still not working, open your media player without any movie and set
> it to use video driver xshm instead of xv.
>
> It will be much slower, but it works for certain. It's the only way to
> see video on my Intel 915, that does not have fbo or pbuffer
> capabilities in the driver.

OK, the plot thickens:

My Tecra M2 laptop is running 10.1 RC1 and the xgl stuff - it plays all the
videos with no problems. The graphics on the laptop is (from lspci):

nVidia Corporation NV34M [GeForce FX Go5200 32M/64M] (rev a1)


The problematic desktop has the following graphics (from lspci):

nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a2)

An older chipset it seems, and it crashed on every attempted video playback,
until some googling turned up some hints leading to successful video playback.

If I say "mplayer dancemonkeyboy.mpg" it crashes instantly.

However if I say "mplayer -vo x11 dancemonkeyboy.mpg" it plays solidly,
whether being dragged around the screen, made transparent, played on the
corner between 2 desktops or what have you.

So clearly, some finite dimensions of the problem have emerged. I know that
for some reason linux vendors won't ship anything capable of playing any
popular video format, which might cause this to be disregarded, except that
the problem also exists in the real player, which is shipped with suse, when
playing *rm files.

So, is this already a known issue, or have I stumbled onto something obscure
with my particular hardware?

Joe






< Previous Next >
References