Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Re: [opensuse] bug fix support by community
  • From: Henne Vogelsang <hvogel@xxxxxxxxxxxx>
  • Date: Thu, 20 Apr 2006 13:23:32 +0200
  • Message-id: <20060420112332.GE15857@xxxxxxxxxxxx>
Hi,

On Thursday, April 20, 2006 at 12:46:23, Pascal Bleser wrote:

> YaST2 should also get a decent way to update existing packages. This
> is currently (as of 10.0) a real pain to do, there's no obvious option.
> You have to select "package categories", go to "zzz all", right click
> on the right pane, "this list..." -> "update if newer version available".

YaST -> System Update does exactly that...

> And while y2pmsh has a "newer" command to show what updates are
> available, it doesn't have a "install-newer" (or similar) command, so
> you have to specify them yourself from the list shown by "newer".

y2pmsh
upgrade
solve
commit

> Now, to come back to YOU... The only real added value of YOU is the
> following additional information:
> - description of the update
> - severity (critical, security, minor, ...)
- scripts
- pre/post install messages

> That information is not available in repository metadata formats as of
> now (neither in YaST2, nor apt-rpm, nor rpm-md and I guess it's not
> possible in red/open-carpet either).

Its included in "our" enhanced rpm-md that we use for the update
dirs.

Henne

--
Henne Vogelsang, Core Services
"Rules change. The Game remains the same."
- Omar (The Wire)

< Previous Next >
Follow Ups