Mailinglist Archive: opensuse (3337 mails)

< Previous Next >
Suse10 and development for AMD64 with AsusK8S motherboard
  • From: "GEJOE DANIEL" <gejoed@xxxxxxxxx>
  • Date: Sat, 8 Apr 2006 11:29:36 +0530
  • Message-id: <11893df30604072259v8f57411x587ae7119197f35d@xxxxxxxxxxxxxx>
Dear All,
Suse10 both eval and rel versions has got problem with Amd64 with Asus
K8S motherboard...We need to manually load the ide-generic drivers
for the installation from the DVD.Even after installing the distro we
need to use the DVD always for booting into the installed system.This
problem was shared once in another forum and reply was like this:
Selva had the some problem during installing suse 10 64bit on a K8S mobo
,AMD 64 . The problem was during the bootup sequence when the system tries
to read from the harddisk it says
" /dev/hda8 waiting for the device to appear .... "(or something like that)
If thats what you are getting then here is the solution
So we identified that the probelm was something to do with the INITRD. The
initrd that comes with the SUSE 10 rc1 system does not have the IDE-GENERIC
drivers. The solution we worked out was to make our own initrd with the
So boot your system with the SUSE CD. Follow till step 4 (the step u
followed to load the drivers and installing) Then when you are in the main
menu the will be a option to BOOT FROM HARDDISK. use that to boot it into
your newly installed system
Once you are inside the new system, launch a shell and follow the steps.
There are two ways to solve this.
-Easy way----------------1 -----------------------1
Just download (RPM) 2.6.14 kernel for suse 64 and install it.It works fine
--the hard way---------------2 -----------------------2
Objective is to make our own INITRD with IDE-GENERIC drivers
For this we need to use MKINTRD script.
1. Open /etc/sysconfig/kernel file
Add the ide-generic to the entry as show below.
INITRD_MODULES="ide-generic something-ert someting-more"
2. Now run the script mkinitrd. It will install the new ram disk.
3. reboot.


none of them worked for me..i even recompiled the 2.6.14 kernal use!!!
Also there's no driver for Sis190 lan card and the graphics display
ought to be improved for Asus motherboards(and i know that they don't
support open source!!)

Hoping for some response..or some changes made for the next release
for which iam eagerly waiting for my Amd64 system...
Atleast please convey this message to the developers..

Thanking in advance,
Gejoe Daniel

< Previous Next >
This Thread
  • No further messages