Mailinglist Archive: opensuse (3767 mails)

< Previous Next >
Strange cups/enscript behaviour, protection problem?
  • From: Peter Sutter <sutterp@xxxxxxxxxxxx>
  • Date: Fri, 3 Feb 2006 23:04:06 +0800
  • Message-id: <200602032304.07010.sutterp@xxxxxxxxxxxx>
I have just re-installed cups on a SuSE V9.2 Linux system. User root
can print, other users can't; to be more precise, I get a printout
as user root, but not when logged in as a non-root. Yet when I
check the cups error log, it looks as if the jobs are getting
printed. (see the entries in cups error.log below). Observing the
printers, in both cases, there is data being sent to the printer
(activity light starts flashing).

In both situations, I attempt to print the same text file using
enscript -P fs_1010_net filename.txt. The printer is a kyocera
fs_1010 printer with a network port, configured as direct port
printing to port 9100.

What goes wrong? cups or enscript?

Thanks for any clues.

Peter

Entry form /var/log/cups/error.log when submitting job as root: This
job printed.
[03/Feb/2006:11:09:28 +0800] Adding start banner page "none" to job
32.
I [03/Feb/2006:11:09:28 +0800] Adding end banner page "none" to job
32.
I [03/Feb/2006:11:09:28 +0800] Job 32 queued on 'fs_1010_net' by
'root'.
I [03/Feb/2006:11:09:28 +0800] Started
filter /usr/lib/cups/filter/pstops (PID 9539) for job 32.
I [03/Feb/2006:11:09:28 +0800] Started
filter /usr/lib/cups/filter/foomatic-rip (PID 9540) for job 32.
I [03/Feb/2006:11:09:28 +0800] Started
backend /usr/lib/cups/backend/socket (PID 9541) for job 32.

Entry form /var/log/cups/error.log when submitting job as sutterp,
this job did not print.
I [03/Feb/2006:11:09:50 +0800] Adding start banner page "none" to
job 33.
I [03/Feb/2006:11:09:50 +0800] Adding end banner page "none" to job
33.
I [03/Feb/2006:11:09:50 +0800] Job 33 queued on 'fs_1010_net' by
'sutterp'.
I [03/Feb/2006:11:09:50 +0800] Started
filter /usr/lib/cups/filter/pstops (PID 9558) for job 33.
I [03/Feb/2006:11:09:50 +0800] Started
filter /usr/lib/cups/filter/foomatic-rip (PID 9559) for job 33.
I [03/Feb/2006:11:09:50 +0800] Started
backend /usr/lib/cups/backend/socket (PID 9560) for job 33.

< Previous Next >
Follow Ups