Mailinglist Archive: opensuse (3767 mails)

< Previous Next >
Re: [SLE] Cannot talk to netgear WGT624 wireless router ??
  • From: Carl Hartung <suselinux@xxxxxxxxxxxxx>
  • Date: Fri, 3 Feb 2006 22:21:19 -0500
  • Message-id: <200602032221.20104.suselinux@xxxxxxxxxxxxx>
On Friday 03 February 2006 21:43, Patrick Shanahan wrote:
> thanks, I tried that:
>
> wahoo:~ # rcnetwork restart eth0
> Shutting down network interfaces: eth0 done
> Setting up network interfaces: eth0 (DHCP) IP/Netmask: 192.168.1.2
> / 255.255.255.0 done
>
> wahoo:~ # ping 192.168.1.1
> PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
>
> --- 192.168.1.1 ping statistics ---
> 4 packets transmitted, 0 received, 100% packet loss, time 3013ms

Hi Patrick,

I've been sitting on (figuratively) a little gem of a post from a while back
that had me puzzled but ended up being highly informative. Here is the
relevant excerpt:

> I have no idea what it is, but all I know is that when I did a
> ifup-dhcp wlan0 -o debug,auto dhcp assigned an address to wlan0

Since the OP complained that "man ifup-dhcp" gave no feedback, I tried and
discovered he was right. So I did some investigating. Here is what I found:

On my system (9.3) I have the following items under /sbin:

ifdown-dhcp -> ifup-dhcp
ifstatus-dhcp -> ifup-dhcp
ifprobe -> ifup
ifstatus -> ifup
ifdown -> ifup
ifconfig

pin revealed these items came from sysconfig-0.32.0-18.2.i586.rpm

I checked for sysconfig documentation and it exists. The file I think you'll
find most interesting is this one:
/usr/share/doc/packages/sysconfig/Network

I don't know why there aren't any man pages for these utilities, but they seem
like they'd be extremely helpful in situations such as your's. The problem
is, I'm not really able to experiment with these right now... a lot going on.
Anyway, I'm hoping you might oblige and tell me what happens, if anything :-)

regards,

- Carl

< Previous Next >
Follow Ups