Mailinglist Archive: opensuse (3767 mails)

< Previous Next >
Re: [SLE] Cannot talk to netgear WGT624 wireless router ??
  • From: Jim Cunning <jcunning@xxxxxxxxxxxxxxx>
  • Date: Sat, 04 Feb 2006 11:32:55 -0800
  • Message-id: <1139081575.1844.54.camel@xxxxxxxxxxxxxxxxxxx>
On Sat, 2006-02-04 at 10:56, Patrick Shanahan wrote:
> * Ken Schneider <suse-list@xxxxxxxxxxxxx> [02-04-06 13:18]:
> >
> > OK. What do you have in /etc/sysconfig/network/routes as this will make
> > a difference. It needs to be 192.168.1.1 for the new router till it is
> > configured.
> >
>
> ok, this leads to another possible solution.
> /etc/sysconfig/network/routes is zero file length and /etc/resolv.conf
> contains nameserver 192.168.0.1
>
> but would that cause a problem with dotted quads and not using names?

I've been following this thread and am coming to the conclusion the
problem may be very basic. It also isn't clear from everything passed
back and forth that you know precisely what does work and what doesn't.

Given that your original router configuration works fine, assigns IP
addresses with DHCP, etc., you can probably conclude there's nothing
wrong with your NIC or workstation network configuration. So, starting
from there:
* When you plug into your new router (using the same cable from
your NIC), do you get a link light on the router?
* If yes, shutdown your workstation network (rcnetwork stop), then
manually configure an IP address on eth0 (ifconfig eth0
192.168.0.100 -- for example).
* If you enter "netstat -rn" you should see a route to 192.168.0.0
via eth0.
* Try pinging the new router "ping 192.168.0.1"
* If you get no response, enter "arp -a" and look for a line
something like

? (192.168.01) at <incomplete> on eth0

This would confirm the router is not responding to that subnet
address.
* Since you've seen IP addresses like 192.168.1.x, change your
NIC's IP address to 192.168.1.100, and try the ping and arp
again.
* If you get no response using either IP address, your router may
be either bad or configured with a different IP address than the
192.168.x.1 addresses tried. Reset the router to factory
defaults using the procedure described in the user manual
(usually a pin or paperclick inserted for 10 seconds into a
small hole at the back of the unit). Try the ping/arp sequence
again.
* If you get a ping response from any of the addresses tried, then
open a web browser to that address, without restarting your
network or changing NIC IP address. Verify that you can get a
response from the router's web server config page, and check the
configuration to be sure DHCP is enabled, etc.
* If none of this works, I would return the router to where you
bought it.

--
Jim Cunning <jcunning@xxxxxxxxxxxxxxx>


< Previous Next >
Follow Ups