Mailinglist Archive: opensuse (3767 mails)

< Previous Next >
Re: [SLE] Strange cups/enscript behaviour, protection problem? SOLVED!
  • From: Peter Sutter <sutterp@xxxxxxxxxxxx>
  • Date: Mon, 6 Feb 2006 20:53:56 +0800
  • Message-id: <200602062053.57065.sutterp@xxxxxxxxxxxx>
On Friday 03 February 2006 23:48, Johannes Meixner wrote:
> Hello,
>
> On Feb 3 23:04 Peter Sutter wrote (shortened):
> > I have just re-installed cups on a SuSE V9.2 Linux system. User
> > root can print, other users can't; to be more precise, I get a
> > printout as user root, but not when logged in as a non-root.
> > Yet when I check the cups error log, it looks as if the jobs
> > are getting printed. (see the entries in cups error.log below).
> > Observing the printers, in both cases, there is data being sent
> > to the printer (activity light starts flashing).
>
> Which makes sense because regardless which user submits a job
> to the printing system, the processes of the printing system
> run always under the same user "lp".
>
> > In both situations, I attempt to print the same text file using
> > enscript -P fs_1010_net filename.txt. The printer is a kyocera
> > fs_1010 printer with a network port, configured as direct port
> > printing to port 9100.
> >
> > What goes wrong? cups or enscript?
>
> Regarding CUPS, see
> http://portal.suse.com/sdb/en/2002/11/jsmeix_print-cups-options.h
>tml
>
> Regarding enscript:
> Try the same as normal user when you did before
> export LC_ALL="POSIX"
> export LANG="POSIX"
> If it works then, it is a problem caused by the normal locale
> setting of this user which may somehow cause enscript to produce
> either PostScript which the printer does not understand
> or the well known error that in a locale where the decimal point
> is a comma the PostScript also contains commas instead of
> decimal points which would result a syntax error in the
> PostScript interpreter.
> To verify print as normal under the normal locale with enscript
> into a file (e.g. echo Hello | enscript ...) and grep for ','.
>
>
> Kind Regards
> Johannes Meixner
> --
> SUSE LINUX Products GmbH, Maxfeldstrasse 5 Mail:
> jsmeix@xxxxxxx 90409 Nuernberg, Germany WWW:
> http://www.suse.de/

Thanks, Johannes

You pointed me in the right direction. I used enscript -p to create
the postscript file as root and as normal user and then compared
the two outputs. The only difference is that root creates an A4
page, whereas non-root users create a letter size page. The kyocera
fs-1010 network printer is set to A4 and does not print letter size
pages, it just does nothing, i.e. flushes the data. I tried the
same with a hp laserjet, which prints both, a4 and letter, so the
problem appears to be caused by a particularity of the printer.

Thanks for your help.

Peter

< Previous Next >
Follow Ups