Mailinglist Archive: opensuse (3336 mails)

< Previous Next >
Onstream ADR SCSI tape on OpenSuse 10
  • From: Ovi <oldkerosen@xxxxxxxxxxxxxx>
  • Date: Thu, 01 Dec 2005 12:41:28 +0100
  • Message-id: <cfd2fe706fb2072ede8e25c794d36640@xxxxxxxxxxxxxxxxxx>
Hi folks,
I'm using OpenSuSE 10.0 on a PIII machine which has a SCSI Onstream ADR 30 internal drive. Under SuSE 7.0-9.0 I used to make backups of the /home directory using the following command:

tar cvf - /home | buffer -s 32k -m 32M -B -t -o /dev/nosst0

Since installing the OS 10.0 the same command gives me an error like:

buffer (writer): write of data failed: Success
bytes to write=32768, bytes written=4096, total written 257536K

I have tried a different approach using the 'dd' command and i get:

#dd if=/dev/sdb1 of=/dev/nosst0 bs=32768
dd: writing `/dev/nosst0': No space left on device
8049+0 records in
8048+0 records out
263720960 bytes (264 MB) copied, 8.96745 seconds, 29.4 MB/s

It seems to me like now there is a (buffer ???) limitation of ~260MB of data that can be written on the tape. I've tried with 5 different tapes that I usually use bot all of them give the same errors.

The 'cat /proc/scsi/sci' gives this output:

Host: scsi0 Channel: 00 Id: 04 Lun: 00
Vendor: OnStream Model: SC-30 Rev: 1.05
Type: Sequential-Access ANSI SCSI revision: 02

None of the 'mt -f /dev/nosst0 status/rewind/reten' works.I have the following software versions:

Linux 2.6.13-15.ck6.SUPER.1-default #1 Tue Sep 13 14:56:15 UTC 2005 i686 i686 i386 GNU/Linux
tar-1.15.1-9
buffer-1.19-711
mt_st-0.7-423.

Any advise is wellcomed!
Thank you,
ovi






< Previous Next >
This Thread
  • No further messages