Mailinglist Archive: opensuse (3336 mails)

< Previous Next >
Re: [SLE] To compile 64 bit?
  • From: "B. Stia" <usr@xxxxxxxxxxx>
  • Date: Fri, 2 Dec 2005 00:46:15 -0500
  • Message-id: <200512020046.16031.usr@xxxxxxxxxxx>
On Thursday 01 December 2005 04:37 am, Joe Morris (NTM) wrote:
> B. Stia wrote:
> > This is what I got when I tried it. Don't understand what the error
> > messages mean.

......<snip some stuff>.....
Hi Joe, Thanks for the explanation.
>
> > Building target platforms: x86_64
> > Building for target x86_64
> > sh: kde-config: command not found
>
> Interesting.
> joe@jmorris:~> locate kde-config
> /opt/kde3/bin/kde-config
> joe@jmorris:~> rpm -qf /opt/kde3/bin/kde-config
> kdelibs3-3.5.0-14

Yeah, me too. Wonder if he has it looking for kde in /user ?
>
> > error: /usr/src/packages/SPECS/smart.spec:44:
> > parseExpressionBoolean returns -1
> > error: Name field must be present in package: (main package)
> > error: Version field must be present in package: (main package)
> > error: Release field must be present in package: (main package)
> > error: Summary field must be present in package: (main package)
> > error: Group field must be present in package: (main package)
> > error: License field must be present in package: (main package)
>
> These are variables usually placed in the spec file, but he must
> place them in his ~.rpmmacros file which is used to build as a user.
> If you added the above to the spec file, it might build. I'm not
> sure since kde-config was not found.

The errors are what I was asking about. the rpmmacros is new to me.
Oh well, maybe I can install the 686 version and see if it will work.

Bob S.
>
> --
> Joe Morris
> Registered Linux user 231871

< Previous Next >