Mailinglist Archive: opensuse (3336 mails)

< Previous Next >
Re: [SLE] KDE 3.5 in SUSE 9.1
  • From: Benjamí Villoslada <benjami@xxxxxxxxx>
  • Date: Fri, 2 Dec 2005 16:15:36 +0100
  • Message-id: <200512021615.38224.benjami@xxxxxxxxx>
El Divendres, 2 de Desembre de 2005 02:03, Mark A. Taff va escriure:

> Then `apt-get -V install kdebase3 kdemultimedia3` and the other kde*
> packages that were held back.

Thanks, -V is more clear that the -s that I've used. Seems that the problem
is with some *devel packages.

One baffle thing:

apt-get with all KDE keept back packages:

# apt-get install -s -V kdeadmin3 kdeartwork3 kdebase3 kdebase3-devel
kdebindings3-javascript kdegames3 kdegraphics3 kdelibs3 kdelibs3-devel
kdemultimedia3 kdemultimedia3-jukebox kdenetwork3 kdepim3
kdepim3-time-management kdetoys3 kdeutils3 kdevelop3
[snip]
The following packages have unmet dependencies:
kdelibs3: Depends: qt3 (>= 3.3.5) but 3.3.4-29 is to be installed
E: Broken packages

but kdelibs3 alone:

# apt-get install -s -V kdelibs3
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
qt3 (3.3.5-22)
qt3-extensions (3.3.5-22)
qt3-mysql (3.3.5-22)
qt3-postgresql (3.3.5-22)
The following packages will be upgraded
kdelibs3 (3.4.3-2 => 3.5.0-14)
qt3 (3.3.4-29 => 3.3.5-22)
qt3-extensions (3.3.4-29 => 3.3.5-22)
qt3-mysql (3.3.4-29 => 3.3.5-22)
qt3-postgresql (3.3.4-29 => 3.3.5-22)
The following packages will be REMOVED:
arts-devel (1.4.2-3)
kdebase3-devel (3.4.3-2)
kdelibs3-devel (3.4.3-2)
kdevelop3 (3.2.3-2)
qt3-devel (3.3.4-8)
qt3-devel-doc (3.3.4-29)
qt3-devel-tools (3.3.4-29)
qt3-man (3.3.4-29)
qt3-non-mt (3.3.4-24)
5 upgraded, 0 newly installed, 9 removed and 311 not upgraded.
Remv arts-devel (1.5.0-5 SuSE:9.1/stable)
Remv kdevelop3 (3.3.0-5 SuSE:9.1/stable)
Remv kdebase3-devel (3.5.0-15 SuSE:9.1/stable)
Remv kdelibs3-devel (3.5.0-14 SuSE:9.1/stable)
Remv qt3-man (3.3.5-22 SuSE:9.1/stable)
Remv qt3-devel-tools (3.3.5-22 SuSE:9.1/stable)
Remv qt3-devel-doc (3.3.5-22 SuSE:9.1/stable)
Remv qt3-devel (3.3.5-22 SuSE:9.1/stable)
Remv qt3-non-mt (3.3.4-24 )
Inst qt3-extensions [3.3.4-29] (3.3.5-22 SuSE:9.1/stable) []
Inst qt3-postgresql [3.3.4-29] (3.3.5-22 SuSE:9.1/stable) []
Inst qt3-mysql [3.3.4-29] (3.3.5-22 SuSE:9.1/stable) []
Inst qt3 [3.3.4-29] (3.3.5-22 SuSE:9.1/stable)
Inst kdelibs3 [3.4.3-2] (3.5.0-14 SuSE:9.1/stable)
Conf qt3 (3.3.5-22 SuSE:9.1/stable)
Conf qt3-extensions (3.3.5-22 SuSE:9.1/stable)
Conf qt3-postgresql (3.3.5-22 SuSE:9.1/stable)
Conf qt3-mysql (3.3.5-22 SuSE:9.1/stable)
Conf kdelibs3 (3.5.0-14 SuSE:9.1/stable)


qt3 >= 3.3.5 is available!

itaca:~ # apt-cache policy qt3
qt3:
Installed: 3.3.4-29
Candidate: 3.3.5-22
^^^^^^^^ !
Version Table:
3.3.5-22 0
500 ftp://ftp4.gwdg.de SuSE/9.1-i386/kde pkglist
500 ftp://ftp4.gwdg.de SuSE/9.1-i386/kde3-stable pkglist
*** 3.3.4-29 0
500 ftp://ftp4.gwdg.de SuSE/9.1-i386/kde3-stable pkglist
100 RPM Database
3.3.1-36.16 0
500 ftp://ftp4.gwdg.de SuSE/9.1-i386/update-prpm pkglist
500 ftp://ftp4.gwdg.de SuSE/9.1-i386/update pkglist
500 ftp://ftp4.gwdg.de SuSE/9.1-i386/security-prpm pkglist
500 ftp://ftp4.gwdg.de SuSE/9.1-i386/security pkglist
3.3.1-36.12 0
500 ftp://ftp4.gwdg.de SuSE/9.1-i386/update pkglist
3.3.1-33 0
500 ftp://ftp4.gwdg.de SuSE/9.1-i386/base pkglist



:?

Regards,


--
Benjamí
http://weblog.bitassa.net



.

< Previous Next >
Follow Ups