Mailinglist Archive: opensuse (3336 mails)

< Previous Next >
Re: [SLE] Mysterious cron problem with Suse 9.3
  • From: Eric E <whalesuit@xxxxxxxxx>
  • Date: Fri, 02 Dec 2005 15:56:43 -0500
  • Message-id: <4390B50B.4020407@xxxxxxxxx>
OK, that resolved it. The cron job now runs. Many thanks to all for your help.



Frank Bax wrote:

At 01:22 PM 12/2/05, Eric E wrote:

Hi all,
I'm running Suse Linux 9.3, and I'm having problems with cron not actually running cron jobs. I suspect this is the kind of profile issue that commonly happens with cron jobs, but I don't have any idea how to debug it.

For example, if as root, I run crontab -e and enter the following very simple cron job:

22 12 * * * /usr/bin/touch /root/hello.root

In /var/log/messages, I have the following output:

Dec 2 12:21:23 hypervisor1 crontab[7015]: (root) BEGIN EDIT (root)
Dec 2 12:21:25 hypervisor1 crontab[7015]: (root) REPLACE (root)
Dec 2 12:21:25 hypervisor1 crontab[7015]: (root) END EDIT (root)
Dec 2 12:22:01 hypervisor1 /usr/sbin/cron[6536]: (root) RELOAD (tabs/root)

Nothing mysterious about it. It alsways works that way. The time is too close to current time. If you want something to run at 12:22, then you must make the change to crontab before 12:21. cron cannot RELOAD at 12:22 *and* execute a task at 12:22 that wasn't there at 12:21.

That's the way it works on every Linux and *bsd system I've ever worked with.

< Previous Next >