Mailinglist Archive: opensuse (2700 mails)

< Previous Next >
Re: [SLE] Puzzling gtk2 issue
  • From: Sid Boyce <sboyce@xxxxxxxxxxxxxxxx>
  • Date: Fri, 01 Jul 2005 22:11:49 +0100
  • Message-id: <42C5B195.50806@xxxxxxxxxxxxxxxx>
Trey Sizemore wrote:
I've been compiling sylpheed-claws from CVS for several weeks on my SUSE
9.3 box with no issues. For the past week, it has failed to compile and
gives the following error:

<snip>
checking for library containing encrypt... -lcrypt
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GTK+ - version >= 2.4.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log
for the
*** exact error that occured. This usually means GTK+ is incorrectly
installed.
configure: error: Test for GTK failed. See the file 'INSTALL' for help.

I've done some upgrades via apt over the past month, so something may
have happened there, but I've not been able to trace the cause of the
issue. I'm hoping someone might be able to point me in the right
direction as far as what to check.


salamander:/home/trey # pkg-config gtk+-2.0 --cflags
-DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -I/opt/gnome/include/gtk-2.0
-I/opt/gnome/lib/gtk-2.0/include -I/usr/X11R6/include
-I/opt/gnome/include/atk-1.0 -I/opt/gnome/include/pango-1.0
-I/usr/include/freetype2 -I/usr/include/freetype2/config
-I/opt/gnome/include/glib-2.0 -I/opt/gnome/lib/glib-2.0/include

Thanks.



Check gtk2-devel is installed.
Regards
Sid.
--
Sid Boyce ... Hamradio License G3VBV, Keen licensed Private Pilot
Retired IBM Mainframes and Sun Servers Tech Support Specialist
Microsoft Windows Free Zone - Linux used for all Computing Tasks

< Previous Next >
Follow Ups
References