Mailinglist Archive: opensuse (2700 mails)

< Previous Next >
Re: [SLE] Qt version issue.
  • From: Anders Johansson <andjoh@xxxxxxxxxx>
  • Date: Sun, 3 Jul 2005 01:49:33 +0200
  • Message-id: <200507030149.34293.andjoh@xxxxxxxxxx>
On Sunday 03 July 2005 01:30, mikael persson wrote:
> [complete linux-newbie alert]
>
> Hello list,
> I am trying to install the latest version of kaffeine in hope of being
> able to watch DVDs and other avi formats. But it complains over a Qt error:
>
> ------------------------------------
> checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (headers
> and libraries) not found. Please check your installation!
> For more details about this problem, look at the end of config.log.
> ------------------------------------
>
> the config.log doesn't tell me much really. Strange thing is that YAST
> claims that that version of Qt is installed.

To run something that uses qt you need qt3 installed, but to compile that
something you need qt3-devel, so make sure you have that installed

> I've also tried installing
> the latest Qt version from trolltech. But that install gives me some
> serious errors.

Whoa there, you can't use qt4 as a drop-in replacement of qt3. Programs need
to be ported in order to be able to use qt4


< Previous Next >
Follow Ups
References