Mailinglist Archive: opensuse (3349 mails)

< Previous Next >
Sound, USB lost in 9.3" - HAL, D-BUS related?
  • From: AD Marshall <admarshall@xxxxxxxxx>
  • Date: Tue, 3 May 2005 12:44:23 +0700
  • Message-id: <18439262050502224471c078aa@xxxxxxxxxxxxxx>
Here's my second massive message on this subject. Feel free to tell me
to work on it more or to get more specific. That's what i'm still
trying to do. Herein, i'm just hoping for some quick direction.

Is there some way I can tweak the following three files to get my USB Flash
drive and sound card working?

Or, given the logextracts and other info below, is there something else I
should do, if only to get more specific info?

Grateful for any help...
AD Marshall


The 3 files I'm hoping can do the trick:

# From /etc/sysconfig/hardware/hwcfg-vpid-8086-7111 ::
# If you change things manually here and want this configuration
# to persist updates, then remove the following line.
# HOTPLUG-FLAG: autocreated
STARTMODE='auto'
MODULE_0='piix'
MODULE_OPTIONS_0=''

# From /etc/sysconfig/hardware/hwcfg-vpid-8086-7112 ::
# HOTPLUG-FLAG: autocreated
STARTMODE='auto'
MODULE_0='uhci-hcd'
MODULE_OPTIONS_0=''

# From /etc/sysconfig/hardware/hwcfg-vpid-8086-7113 ::
# HOTPLUG-FLAG: autocreated
STARTMODE='auto'
MODULE_0='i2c-piix4'
MODULE_OPTIONS_0=''


# From /etc/modprobe.conf
# =======================

install ata_piix /sbin/modprobe ahci; /sbin/modprobe --ignore-install ata_piix


# Some HAL & USB related extracts from /var/log/messages, possibly
related to this:
# ================================================================================

Apr 29 18:03:34 tpad01 kernel: piix4_smbus 0000:00:07.3: Found
0000:00:07.3 device
Apr 29 18:03:34 tpad01 kernel: piix4_smbus 0000:00:07.3: IBM Laptop
detected; this module may corrupt your serial eeprom! R
efusing to load module!
Apr 29 18:03:34 tpad01 kernel: piix4_smbus: probe of 0000:00:07.3
failed with error -1

# Note: Inserted CD

Apr 29 18:30:34 tpad01 kernel: subfs 0.9
Apr 29 18:30:34 tpad01 hal-subfs-mount[7420]: registered at resmgrd
and called(0) /bin/mount -t subfs -o
fs=cdfss,ro,procuid,nosuid,nodev,exec /dev/hdc "/media/FORGE80"
Apr 29 18:30:36 tpad01 hal.hotplug[7432]: DEVPATH is not set
Apr 29 18:30:38 tpad01 hal.hotplug[7435]: DEVPATH is not set
Apr 29 18:31:37 tpad01 hal.hotplug[7459]: DEVPATH is not set
Apr 29 18:31:40 tpad01 hal.hotplug[7465]: DEVPATH is not set

# Note: Inserted Kingston DataTraveller USB stick

Apr 29 18:31:52 tpad01 kernel: usb 1-1: new full speed USB device
using uhci_hcd and address 2
Apr 29 18:31:53 tpad01 kernel: uhci_hcd 0000:00:07.2: Unlink after
no-IRQ? Controller is probably using the wrong IRQ.
Apr 29 18:31:56 tpad01 kernel: usb 1-1: device descriptor read/64, error -110
Apr 29 18:32:12 tpad01 kernel: usb 1-1: device not accepting address
2, error -110
Apr 29 18:32:12 tpad01 kernel: usb 1-1: new full speed USB device
using uhci_hcd and address 3
Apr 29 18:32:24 tpad01 kernel: usb 1-1: device not accepting address
3, error -110
Apr 29 18:32:24 tpad01 kernel: usb 1-1: new full speed USB device
using uhci_hcd and address 4
Apr 29 18:32:34 tpad01 kernel: usb 1-1: device not accepting address
4, error -110
Apr 29 18:32:34 tpad01 kernel: usb 1-1: new full speed USB device
using uhci_hcd and address 5
Apr 29 18:32:45 tpad01 kernel: usb 1-1: device not accepting address
5, error -110
Apr 29 18:41:20 tpad01 su: (to root) am on /dev/pts/5
Apr 29 19:03:25 tpad01 syslog-ng[3309]: STATS: dropped 0
Apr 29 20:25:46 tpad01 su: (to root) am on /dev/pts/2
Apr 29 20:25:46 tpad01 syslog-ng[3309]: STATS: dropped 0

# Note: modprobe ata_piix
# Note: ReInserted Kingston DataTraveller USB stick

Apr 29 21:24:43 tpad01 kernel: libata version 1.10 loaded.
Apr 29 21:25:46 tpad01 syslog-ng[3309]: STATS: dropped 0
Apr 29 21:26:01 tpad01 kernel: usb 1-1: new full speed USB device
using uhci_hcd and address 6
Apr 29 21:26:04 tpad01 kernel: usb 1-1: device descriptor read/64, error -110
Apr 29 21:26:20 tpad01 kernel: usb 1-1: device not accepting address
6, error -110
Apr 29 21:26:20 tpad01 kernel: usb 1-1: new full speed USB device
using uhci_hcd and address 7
Apr 29 21:26:32 tpad01 kernel: usb 1-1: device not accepting address
7, error -110
Apr 29 21:26:32 tpad01 kernel: usb 1-1: new full speed USB device
using uhci_hcd and address 8
Apr 29 21:26:43 tpad01 kernel: usb 1-1: device not accepting address
8, error -110
Apr 29 21:26:43 tpad01 kernel: usb 1-1: new full speed USB device
using uhci_hcd and address 9
Apr 29 21:26:54 tpad01 kernel: usb 1-1: device not accepting address
9, error -110
Apr 29 21:29:06 tpad01 kernel: usb 1-1: new full speed USB device
using uhci_hcd and address 10
Apr 29 21:29:10 tpad01 kernel: usb 1-1: device descriptor read/64, error -110
Apr 29 21:29:26 tpad01 kernel: usb 1-1: device not accepting address
10, error -110
Apr 29 21:29:26 tpad01 kernel: usb 1-1: new full speed USB device
using uhci_hcd and address 11
Apr 29 21:29:38 tpad01 kernel: usb 1-1: device not accepting address
11, error -110
Apr 29 21:29:38 tpad01 kernel: usb 1-1: new full speed USB device
using uhci_hcd and address 12
Apr 29 21:29:48 tpad01 kernel: usb 1-1: device not accepting address
12, error -110
Apr 29 21:29:48 tpad01 kernel: usb 1-1: new full speed USB device
using uhci_hcd and address 13
Apr 29 21:29:59 tpad01 kernel: usb 1-1: device not accepting address
13, error -110

# Note: ran :: # modprobe -r ata_piix
# Note: ReInserted Kingston DataTraveller USB stick

Apr 29 21:35:25 tpad01 kernel: usb 1-1: new full speed USB device
using uhci_hcd and address 14
Apr 29 21:35:28 tpad01 kernel: usb 1-1: device descriptor read/64, error -110
Apr 29 21:35:44 tpad01 kernel: usb 1-1: device not accepting address
14, error -110
Apr 29 21:35:44 tpad01 kernel: usb 1-1: new full speed USB device
using uhci_hcd and address 15
Apr 29 21:35:56 tpad01 kernel: usb 1-1: device not accepting address
15, error -110
Apr 29 21:35:56 tpad01 kernel: usb 1-1: new full speed USB device
using uhci_hcd and address 16
Apr 29 21:36:06 tpad01 kernel: usb 1-1: device not accepting address
16, error -110
Apr 29 21:36:06 tpad01 kernel: usb 1-1: new full speed USB device
using uhci_hcd and address 17
Apr 29 21:36:17 tpad01 kernel: usb 1-1: device not accepting address
17, error -110


# Some sound-related extracts from /var/log/messages ::
=======================================================

# Note: Tried to play an mp3 in alsaplayer

Apr 29 23:32:38 tpad01 kernel: ALSA sound/core/pcm_lib.c:2113:
playback write error (DMA or IRQ trouble?)
Apr 29 23:32:48 tpad01 kernel: ALSA sound/core/pcm_lib.c:2113:
playback write error (DMA or IRQ trouble?)
Apr 29 23:32:58 tpad01 kernel: ALSA sound/core/pcm_lib.c:2113:
playback write error (DMA or IRQ trouble?)
<cut>
Apr 29 23:34:48 tpad01 kernel: ALSA sound/core/pcm_lib.c:2113:
playback write error (DMA or IRQ trouble?)
Apr 29 23:34:58 tpad01 kernel: ALSA sound/core/pcm_native.c:1433:
playback drain error (DMA or IRQ trouble?)


# /proc/interrupts, ::
======================

CPU0
0: 26516950 XT-PIC timer
1: 19914 XT-PIC i8042
2: 0 XT-PIC cascade
3: 56 XT-PIC 1.0
7: 0 XT-PIC parport0
8: 2 XT-PIC rtc
9: 5766 XT-PIC acpi
10: 200001 XT-PIC yenta
11: 100000 XT-PIC yenta, uhci_hcd, CS46XX
12: 76415 XT-PIC i8042
14: 175790 XT-PIC ide0
15: 53271 XT-PIC ide1
NMI: 0
LOC: 0
ERR: 0
MIS: 0


# /proc/ioports ::
==================

1 0000-001f : dma1
2 0020-0021 : pic1
3 0022-0022 : PM2_CNT_BLK
4 0040-0043 : timer0
5 0050-0053 : timer1
6 0060-006f : keyboard
7 0070-0077 : rtc
8 0080-008f : dma page reg
9 00a0-00a1 : pic2
10 00c0-00df : dma2
11 00f0-00ff : fpu
12 0170-0177 : ide1
13 01f0-01f7 : ide0
14 02f8-02ff : serial
15 0300-031f : pcmcia_socket1
16 0376-0376 : ide1
17 03bc-03be : parport0
18 03c0-03df : vesafb
19 03f6-03f6 : ide0
20 03f8-03ff : serial
21 0cf8-0cff : PCI conf1
22 15e0-15ef : motherboard
23 15e0-15ef : pnp 00:07
24 4000-401f : 0000:00:07.2
25 4000-401f : uhci_hcd
26 4400-44ff : 0000:00:03.0
27 4500-4507 : 0000:00:03.0
28 4800-48ff : PCI CardBus #02
29 4c00-4cff : PCI CardBus #02
30 5000-50ff : PCI CardBus #06
31 5400-54ff : PCI CardBus #06
32 d000-dfff : PCI Bus #01
33 ef00-ef3f : 0000:00:07.3
34 ef00-ef3f : motherboard
35 ef00-ef03 : PM1a_EVT_BLK
36 ef04-ef05 : PM1a_CNT_BLK
37 ef08-ef0b : PM_TMR
38 ef0c-ef0f : GPE0_BLK
39 ef10-ef15 : ACPI CPU throttle
40 efa0-efbf : 0000:00:07.3
41 efa0-efaf : motherboard
42 efa0-efaf : pnp 00:07
43 fcf0-fcff : 0000:00:07.1
44 fcf0-fcf7 : ide0
45 fcf8-fcff : ide1

--
AD (Andi) Marshall
admarshall@xxxxxxxxx

< Previous Next >
This Thread
  • No further messages