Mailinglist Archive: opensuse (3349 mails)

< Previous Next >
Does samba server require cups daemon
  • From: Allison Maury <alli@xxxxxxxxxx>
  • Date: Thu, 12 May 2005 15:46:35 +0200
  • Message-id: <42835E3B.3020908@xxxxxxxxxx>
Hi everyone,

I'm new to SUSE (and linux admin in general) and am trying to configure a samba server using yast. When I start the yast samba server configuration tool, it hangs at 50% on printer settings (I then have to kill yast). As the machine is a file server and I haven't had the need, I don't have any printer set up for this machine.

To attempt to get past this hanging point, I tried to set up a printer, during which I get "Error CUPS daemon died during initialization" and two different points. Since the machine is a file server, I tried to minimalize what I installed on it. So, I only have cups-client, cups-libs, cups-libs-32bit, and xpp installed. From chkconfig --list, I don't see any cups daemon listed.

With this information, I'd appreciate any suggestions/advice on how to get the samba server configuration tool to stop hanging. Does samba require cups to be running? Do I need to set up cups? Do I need to install more packages?
Thanks for any and all advice!
Allison
< Previous Next >
Follow Ups