Mailinglist Archive: opensuse (3349 mails)

< Previous Next >
mounting problem
  • From: Greg Bradner <gregb@xxxxxxxxxx>
  • Date: Wed, 18 May 2005 09:17:53 -0700
  • Message-id: <428B6AB1.3090207@xxxxxxxxxx>

I'm new to the list and apologize if this is a rehash.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


This happens with autofs or using mount directly.

However I mount the disk the first time, the same characteristics are passed to future mounts.

## This is a read only mount point and you can see the options in the /proc/mounts file at the bottom
cd /nfs/ro3/fs14/a/rla/

df -k .
Filesystem 1K-blocks Used Available Use% Mounted on
fs14:/a/rla 657148928 545010048 112138880 83% /nfs/ro3/fs14/a/rla

## Then when I go to a mount point that shouldn't be read only, it take the options from the previous mount.
cd /fs14a/rla/

df -k .
Filesystem 1K-blocks Used Available Use% Mounted on
fs14:/a/rla 657148928 545010048 112138880 83% /fs14a/rla

touch test
touch: cannot touch `test': Read-only file system

tail /proc/mounts
automount(pid3481) /ntap10 autofs rw 0 0
automount(pid3599) /morph autofs rw 0 0
automount(pid3538) /systems autofs rw 0 0
/dev/hda7 /home/gregb ext3 rw 0 0
fs14:/a/jobs /nfs/ro3/fs14/a/jobs nfs ro,v3,rsize=32768,wsize=32768,hard,intr,udp,lock,addr=fs14 0 0
fs14:/a/rla /nfs/ro3/fs14/a/rla nfs ro,v3,rsize=32768,wsize=32768,hard,intr,udp,lock,addr=fs14 0 0
fs14:/b/rla /nfs/ro3/fs14/b/rla nfs ro,v3,rsize=32768,wsize=32768,hard,intr,udp,lock,addr=fs14 0 0
fs14:/root0 /nfs/ro3/fs14/root0 nfs ro,v3,rsize=32768,wsize=32768,hard,intr,udp,lock,addr=fs14 0 0
fs14:/root1 /nfs/ro3/fs14/root1 nfs ro,v3,rsize=32768,wsize=32768,hard,intr,udp,lock,addr=fs14 0 0
fs14:/a/rla /fs14a/rla nfs ro,nosuid,nodev,v3,rsize=32768,wsize=32768,hard,intr,udp,lock,addr=fs14 0 0


What is the culprit and is there a fix?

--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
gregb@xxxxxxxxxx



< Previous Next >
This Thread
  • No further messages