Mailinglist Archive: opensuse (3349 mails)

< Previous Next >
Who killed Windows? How resurrect?
  • From: AD Marshall <admarshall@xxxxxxxxx>
  • Date: Fri, 20 May 2005 13:09:28 +0700
  • Message-id: <200505201309.29021.admarshall@xxxxxxxxx>
To answer the 1st question, probably me, when i accidentally copy-
pasted some text i was editing into a root prompt. Duh. Worse, i might
have screwed up the original MBR by using dosfsck.

But the real issue is how to get it, Windows 2000, back?

Note: the Windows partition in question is still mountable and is
automounted via /etc/fstab when SuSE 9.3 boots up, but i can't boot
into Windows.

What happened?

* I tried to boot into Win2K via GRUB last night and got this response
for the first time (after many previous successful boot-ups -- comments
added):

root (hd0,0) #<- from /boot/grub/menu.lst
Filesystem is type fat,
partition type 0xc
chainloader+1 #<- from /boot/grub/menu.lst
Boot failed

* BEFORE READING at linuxquestions.org that i might be able to fix this
by replacing old GRUB commands in the Windows 2000 entry in
"/boot/grub/menu.lst" (above) with:
rootnoverify (hd0,0)
makeactive
chainloader +1
boot
I TRIED THIS:
# unmount /dev/hda1
# dosfsck -r /dev/hda1
and was told the MBR didn't match the one "backed up" (noting there
exists a file "/boot/back_mbr", 512b in size, on /dev/hda7, in my box).
Then dosfsck asked if I wanted to copy the backed up MBR to the MBR
(or something like that, as choice 2) or do the opposite (choice 1) .

I chose 2 (and crossed my fingers -- which didn't work, yet again).

* Now, i can boot into Windows but can only get a "C:\>" prompt, with a
very limited command set available. "C:\boot.ini" is still there and
*looks* OK, but i'm not sure what to do and am afraid to try more
without knowing more.

I naively tried the alternate code, above, for /boot/grub/menu.lst, but
it doesn't work (now?)

Thanks in advance for any help.

best,
Andi

< Previous Next >
Follow Ups