Mailinglist Archive: opensuse (3349 mails)

< Previous Next >
Re: [SLE] Please Help ! gtk fonts
On Sun, 22 May 2005 15:43:33 -0400
Felix Miata <mrmazda@xxxxxx> wrote:

> B. Stia wrote:
>
> > Found an app called Qt Settings (is that the gtk-qt-engine
> > interface?) which I ran and appears as that should do what is
> > needed.
>
> Where did you find it? I find it with an rpm query, but find no way to
> use it for anything.
>
> I opened YaST in my 9.2 and looked into install/remove software. These
> are among what I found there indicated as installed:
>
> control-center - The Gnome Control Center 1.4.0.5-64.1
> provides: gncontr, libcapplet.so.0
>
> control-center2 - The Gnome Control Center for the Gnome 2.x Desktop
> 2.6.1-25.1 provides: fontilus, themus, acme, libfont.method.so,
> libgnome-window-settings-so.1, libmetacity.so, libtheme-method.so,
> libthemus-theme-properties-view.so
>
> gtk-qt-engine - GTK-style Engine for Use with Qt Plugins and Settings
> 0.5-9.3 provides: libqtengine.so
>
> Trying to run any of them is another matter. I can't find any of the
> indicated provides in the menus, nor can I run any of them from a
> Konsole prompt. Other distros provide gnomecc in their control-center
> rpms for controlling gtk1 apps, and gnome-control-center in the
> control-center2 rpm for controlling gtk2 apps. I have no idea what
> they do for gtk-qt-engine, as it was only in this series of tiny fonts
> threads that I discovered its existence. I can't find it anywhere in
> the KDE menu tree. What is SuSE doing providing us with these
> apparently useless Gnome/gtk rpms? What are they there for? How do we
> use them?

I'm having the same issue. I can't find the gtk-qt engine options even
though it's installed. It does not appear in the KDE Control panel or
K -> Applications as other have found. I remember seeing it before (in
SUSE 9.2 I believe), but it's conspicuously absent on my 9.3 install.

My issue is that Sylpheed-Claws 1.9.11 will not display colored text
for my mail folders nor let me color label messages in those folders in
KDE. This works fine if I'm using Gnome. I've even tried different
Gnome themes to see if that might be the issue.

Interestingly enough, I might have been on the right track as certain
Gnome themes would allow me to start sylpheed-claws in KDE with the
colored folders displayed, but the app would quickly segfault. With
these themes, apps like Evolution and Gaim would also not start.
Switching back to something like the default Gnome theme in 9.3
(Industrial) allows those apps to start, but Claws will not display the
colored messages.

I was hoping the gtk-qt engine would help to address this or maybe
someone else had a clue about what might be causing this.

This is not across the board, however, as those same gnome themes on my
FreeBSD box allow sylpheed-claws to display the colors in KDE there
(also using Gnome 2.10 and KDE 3.4).

Any ideas?

--
Cheers,
Trey
----

"Reality is that which, when you stop believing in it, doesn't go
away".
-- Philip K. Dick

Linux salamander 2.6.11.4-20a-default i686 i686 GNU/Linux
6:04pm up 2:12, 3 users, load average: 0.04, 0.10, 0.41

< Previous Next >
References