Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
Re: [SLE] Printing from cups stopped working! [SOLVED]
  • From: "Carlos E. R." <robin1.listas@xxxxxxxxxx>
  • Date: Tue, 1 Mar 2005 21:40:59 +0100 (CET)
  • Message-id: <Pine.LNX.4.58.0503012134410.7329@xxxxxxxxxxxxxxxx>

The Tuesday 2005-03-01 at 21:27 +0100, Carlos E. R. wrote:

> What is wrong?
>
> Cups, in "http://localhost:631/printers/lp";, says:
>
> Description: default configuration
> Location: local
> Printer State: stopped, accepting jobs.
> "Unable to open parallel port device file "/dev/lp0": Permission denied" <----
> Device URI: parallel:/dev/lp0
>
> Permission denied? What? Printer is defined "crw-rw---- root lp", the same
> as the other ports. Should it be different?

A minute after sending that, it occurred to me to try another "printer",
like lpg (for gimp driver) instead of lp in cups. I think it worked. Then
I happened to click the "start" button in the
"http://localhost:631/printers"; page, "lp" entry - and it did start!

It seems the local cold is not only freezing my fingers, but my neurones
as well O:-)

What I still don't understand is how the device "/dev/lp0" came to be
deleted, nor why cups, even after a restart, did not recognize the printer
was there again an insisted in not printing.

:-O

--
Cheers,
Carlos Robinson


< Previous Next >
References