Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
Re: [SLE] Printing from cups stopped working! [SOLVED]
  • From: "Carlos E. R." <robin1.listas@xxxxxxxxxx>
  • Date: Thu, 3 Mar 2005 21:59:14 +0100 (CET)
  • Message-id: <Pine.LNX.4.58.0503032147540.9071@xxxxxxxxxxxxxxxx>

The Thursday 2005-03-03 at 23:49 +1100, Graham Smith wrote:

> On Thu, 3 Mar 2005 13:35, Carlos E. R. wrote:
> >
> > But the fact the printer was disabled was not logged to syslog, as far as
> > I could see (and I'm used to read logs). Also, "lpq" complained that "lp
> > is not ready", not "lp is disabled" - the message can be confusing, as it
> > refers to the cups printer or whatever, and not the device port of the
> > same name, as it seemed to me. Command lpr said nothing, as usual.
> >
> You should use lpstat it will tell you far more of what is happening than any
> of the GUI apps. Try using:-
> lpstat -t
> and have a look at the results.

Seems good :-)

But I still would like to see the problem logged to syslog as well,
because that't the first place to look at when there are problems.

The first error entry I find in /var/log/cups/error_log was this one (the
line starting with E):

I [01/Mar/2005:18:32:09 +0100] Job 128 queued on 'lp' by 'cer'.
I [01/Mar/2005:18:32:09 +0100] Started filter /usr/lib/cups/filter/pstops (PID 9755) for job 128.
I [01/Mar/2005:18:32:09 +0100] Started filter /usr/lib/cups/filter/foomatic-rip (PID 9756) for job 128.
I [01/Mar/2005:18:32:09 +0100] Started backend /usr/lib/cups/backend/parallel (PID 9757) for job 128.
I [01/Mar/2005:18:35:07 +0100] Job 128 was cancelled by 'cer'.
I [01/Mar/2005:18:35:36 +0100] Adding start banner page "none" to job 129.
I [01/Mar/2005:18:35:36 +0100] Adding end banner page "none" to job 129.
I [01/Mar/2005:18:35:36 +0100] Job 129 queued on 'lp' by 'cer'.
I [01/Mar/2005:18:35:36 +0100] Started filter /usr/lib/cups/filter/pstops (PID 9775) for job 129.
I [01/Mar/2005:18:35:36 +0100] Started filter /usr/lib/cups/filter/foomatic-rip (PID 9776) for job 129.
I [01/Mar/2005:18:35:36 +0100] Started backend /usr/lib/cups/backend/parallel (PID 9777) for job 129.
I [01/Mar/2005:18:36:13 +0100] Adding start banner page "none" to job 130.
I [01/Mar/2005:18:36:13 +0100] Adding end banner page "none" to job 130.
I [01/Mar/2005:18:36:13 +0100] Job 130 queued on 'lp' by 'cer'.
I [01/Mar/2005:18:36:33 +0100] Started filter /usr/lib/cups/filter/texttops (PID 9791) for job 130.
I [01/Mar/2005:18:36:33 +0100] Started filter /usr/lib/cups/filter/pstops (PID 9792) for job 130.
I [01/Mar/2005:18:36:33 +0100] Started filter /usr/lib/cups/filter/foomatic-rip (PID 9793) for job 130.
I [01/Mar/2005:18:36:33 +0100] Started backend /usr/lib/cups/backend/parallel (PID 9794) for job 130.
I [01/Mar/2005:18:36:33 +0100] Job 129 was cancelled by 'cer'.

E [01/Mar/2005:18:47:03 +0100] [Job 130] Unable to open parallel port device file "/dev/lp0": Permission denied
E [01/Mar/2005:18:47:03 +0100] PID 9794 stopped with status 1!

I [01/Mar/2005:18:47:03 +0100] Hint: Try setting the LogLevel to "debug" to find out more.
E [01/Mar/2005:18:47:03 +0100] PID 9793 stopped with status 9!
I [01/Mar/2005:18:47:03 +0100] Hint: Try setting the LogLevel to "debug" to find out more.
I [01/Mar/2005:18:47:03 +0100] Saving printers.conf...
I [01/Mar/2005:18:47:25 +0100] Job 130 was cancelled by 'cer'.
I [01/Mar/2005:18:47:33 +0100] Scheduler shutting down normally.



Notice that the error appears after I had sent two jobs to the printer,
that failed, and after I had investigated for about 15 minutes. Nowhere it
says that /dev/lp0 has dissapeared, but "permission denied". By that time,
it could be when I had already recreated the device, but with wrong
ownership.



--
Cheers,
Carlos Robinson

< Previous Next >