Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
Re: [SLE] Breaking and fixing YaST
  • From: Kastus <NOSPAM@xxxxxxxxxx>
  • Date: Tue, 8 Mar 2005 14:21:04 -0800
  • Message-id: <20050308222104.GA14979@xxxxxxxxxx>
On Tue, Mar 08, 2005 at 03:54:50PM -0600, Bob Apthorpe wrote:
> The key parts of yast2-func are the tests
>
> /usr/bin/ldd "/usr/lib/YaST2/plugin/libpy2ncurses.so.2" \
> | grep "=> not found"
>
> /usr/bin/ldd "/usr/lib/YaST2/plugin/libpy2qt.so.2" \
> | grep "=> not found"
>
> which showed that these libraries couldn't find libcurl.so.2.
>
> It turns out that I had updated curl recently and apparently
> /usr/lib/libcurl.so.2 disappeared in the process. I reverted my curl
> upgrade and as if by magic YaST started working again.

What SUSE version are you running? I just installed curl-7.12.0-2.2
on 9.2 and both libraries happily resolve with libcurl.so.3
provided by curl rpm.

-Kastus

< Previous Next >
Follow Ups
References