Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
Re: [SLE] installing error
  • From: "N. Eschricht" <eschricht@xxxxxx>
  • Date: Mon, 21 Mar 2005 13:53:48 +0100
  • Message-id: <423EC3DC.4000205@xxxxxx>
Yosy Dayan wrote:
I tried to install lmule-1.2.1.tar.gz and get the following errors:

checking for C++ compiler default output... configure: error: C++
compiler cannot create executables

Does anyone knows how to resolve this problem?? I'm running suse 9.2 and
I already have libstdc++-3.3.4-11 running. Is it require libc to be
installed? If so, where can I find it for suse

Thx


Do you have gcc installed correctly? 'configure' tries to compile a very small programm to see if a file named 'a.out' is produced. Try do cp a file to the folder where you try to compile lmule. Maybe you don't have write permission (try 'whoami' and compare the output with the owner of the files (use 'ls -l' to see it)) or the files have strange permissions set. Change the folder permission recursivly with 'chmod -R 754 .' then.
Or try amule instead. You can find it at sourceforge.net and you don't need to compile it. You should uninstall all the wxWindows stuff which on the Suse CD's (and maybe installed) and install only the wx-RPMs given at the amule/sourceforge site, before installing the amule RPM. Otherwise the installation will fail. AMule isn't ready yet for GTK2 and wxWidgets, thats why you need the old wxWindows stuff. But amule works fine.

Regards,
N. Eschricht

< Previous Next >
References