Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
Re: [SLE] gpg-agent & kmail 1.8
  • From: Christopher Shanahan <cshanahan@xxxxxxxxxxx>
  • Date: Tue, 22 Mar 2005 14:35:14 -0500
  • Message-id: <200503221435.38356.cshanahan@xxxxxxxxxxx>
On Tuesday 22 March 2005 14:01, Randall R Schulz wrote:
> Christopher,
>
> On Tuesday 22 March 2005 10:54, Christopher Shanahan wrote:
> > Hello all.
> >
> > Just upgraded my SUSE 9.2 Pro system from kde-3.3 to 3.4. I use kmail
> > for all my e-mail needs with integrated gpg for signing mail. I've
> > never had any problems with gpg in the past. gpg-agent was set to
> > start when I started my system and it would prompt me for my
> > passphrase when I sent e-mail. However, now when I start my machine I
> > get an error message about gpg-agent not running. Regardless of what
> > I do, I cannot get gpg-agent to run correctly. And, when I send
> > e-mail I get the following error message:
>
> Is it possible that this is another manifestation of the missing
> dependencies in the newly supplied KDE packages that allow installation
> to proceed without all the required cyrus-sasl packages?
>
> It couldn't hurt to run YaST Install and Remove Software, search for
> packages that include "cyrus-sasl" and install all except the -devel
> package.
>
> Then see if your symptoms remain.

Thank you for your thoughts, Randall. I have all the cyrus packages installed
and I'm still having kmail/gpg problems. For example, when restarting my
machine I get the following error message:

The use of GnuPG Agent is enabled in GnuPG's configuration file
(/home/cms/.gnupg/gpg.conf).
However, the agent does not seem to be running. This could result in
problems with signing/decryption.
Please disable GnuPG Agent from KGpg settings, or fix the agent.

Truth is, I'm not really sure if the problem deals specifically with kmail or
gpg --or both.

Thanks though.

Christopher Shanahan
< Previous Next >
Follow Ups