Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
Re: [SLE] SMTP Auth howto for 8.2 Professional.
  • From: Preston Kutzner <grdnwsl@xxxxxxxxxx>
  • Date: Thu, 24 Mar 2005 11:46:38 -0600
  • Message-id: <4242FCFE.80606@xxxxxxxxxx>
Sandy Drobic wrote:
> Preston Kutzner wrote:
>
>> List,
>>
>> I'm trying to set up smtp auth in our network. I've got our mail relay
>> working with it, but I can't seem to get it working under 8.2. I know
>> SuSE does some funny things with their config files due to Yast, so I'm
>> wondering what I'm missing. I have it pretty much set up as the relay
>> (at least all the main config files for postfix and sasl), and it's set
>> to use the saslauthd mechanism through pam. However, smtpd won't
>> authenticate, it fails every time. What am I missing as far as the SuSE
>> way of things goes? Thanks in advance.
>>
> What does the log say when you try to authenticate?
> Is saslauthd actually up and running?
>
>
> Sandy
>
saslauthd is running and the only errors I get are:

Mar 24 11:42:31 ein postfix/smtpd[12865]: warning: SASL authentication
failure: Can only find author/en (no password)
Mar 24 11:42:31 ein postfix/smtpd[12865]: warning:
unknown[192.168.56.17]: SASL PLAIN authentication failed

I've even re-used config files from my working relay, just modified for
this machine. This is the same error I get if I try to use the auxprop
plugin as well. So, I'm not sure what the deal is. This *should* be
working, as I have it pretty much set up like I have my relay set up. I
just want our internal mail system's SMTP to match our relay's, that way
people don't have to change their settings depending on their location.
I'd just like to make it work without them having to worry about it.
< Previous Next >