Mailinglist Archive: opensuse (3666 mails)

< Previous Next >
Re: [SLE] gpg-agent & kmail 1.8
  • From: Hamish <lists@xxxxxxxxxxx>
  • Date: Wed, 30 Mar 2005 15:47:44 +0100
  • Message-id: <200503301547.55498.lists@xxxxxxxxxxx>
On Wednesday 23 March 2005 18:07, Christopher Shanahan wrote:
> On Tuesday 22 March 2005 23:42, Darryl Gregorash wrote:
> > Your last two messages in this thread contain what appears to be a valid
> > pgp signature. However, it does not seem to have been published, either
> > on pgp.net or keyserver.net. According to the header information, both
> > were written with kmail 1.8. Whatever problems do exist with your
> > configuration, something does seem to be working.
>
> Yes, my mail seems to be getting signed correctly provided I input my
> passphrase when prompted to do so. I have no problem with that. However, I
> still get error messages related to gpg-agent, both when I send mail using
> kmail and when my system starts -- gpg-agent is set to start automatically
> -- even though gpg-agent is running. The problem seems to be some sort of
> conflict with openssl and one of the new kde packages, I just don't know
> which one. Too many packages depends on openssl for me to easily narrow the
> list of possible culprits.
>
> Of course, I could be way off base here; however, the error messages
> from .xsession-errors (thanks Randall) suggest to me that the problem deals
> with openssl since libcrypto.so.0.9.7 is provided by openssl. You tell me.
> Is the following error message saying the problem is related to openssl or
> some other kde/qt package?
>
> kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.7:
> undefined symbol: PKCS7_content_free
> kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.7:
> undefined symbol: OpenSSL_add_all_algorithms
> kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.7:
> undefined symbol: OpenSSL_add_all_algorithms_conf
> kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libcrypto.so.0.9.7:
> undefined symbol: OpenSSL_add_all_algorithms_noconf
> gpgmeplug checkMessageSignature status flags: 80
>
> I've spent a fair amount of time searching the kde bug database but I
> cannot find any 'new' bugs for this issue as it relates to kde-3.4. I'll
> keep searching though.
>
> Again, thanks to all for their responses/hints.
>
> Christopher Shanahan

Solved! I found that if I create a directory called env in ~/.kde and put in a
shell script to start gpg-agent, it works perfectly (i found this by looking
at startkde).
So to fix: create a directory ~/.kde/env and put in this file:
#!/bin/bash
eval "$(gpg-agent --daemon)"

Make it executable, and you are good to go, restart x, and it Just Works (TM)
Now you can type in your GPG passphrase once, and it will be remembered for a
while so you dont have to eg. type it in 6 times for replying to encrypted
mail! It also stops kgpg complaining that the agent is not running.

Hope that helps,
H
< Previous Next >