Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] SuSE9.2 - kernel: Losing some ticks...checking if CPU frequency changed.
  • From: Anders Johansson <andjoh@xxxxxxxxxx>
  • Date: Thu, 3 Feb 2005 08:34:33 +0100
  • Message-id: <200502030834.33450.andjoh@xxxxxxxxxx>
On Wednesday 02 February 2005 15:14, Mario Ohnewald wrote:
> Hello List,
>
> i have a K7S8X ASROCK motherboard, 256MB ram and an AMD Duron 1.6Ghz.
> When i try to install suse9.2 from a FTP-DVD, i get this error on tty4
> and it freezes:
> kernel: Losing some ticks...checking if CPU frequency changed.
>
> I have already tried apci=off and SafeSettings.
> Then i loaded the default Bios settings, and took out my PCI modem,
> disabled onboard Audio and Lan.
> Memtest ran 12h and its ok.
> Has anyone ideas how i could solve this?!
> FTP or NFS install freezes with the same error.

It doesn't have to be dangerous. In the kernel source we find

/* sanity check to ensure we're not always losing ticks */
if (lost_count++ > 100) {
printk(KERN_WARNING "Losing too many ticks!\n");
printk(KERN_WARNING "TSC cannot be used as a
timesource.
\n");
printk(KERN_WARNING "Possible reasons for this are:
\n");
printk(KERN_WARNING " You're running with Speedstep,
\n"
);
printk(KERN_WARNING " You don't have DMA enabled for
yo
ur hard disk (see hdparm),\n");
printk(KERN_WARNING " Incorrect TSC synchronization
on
an SMP system (see dmesg).\n");
printk(KERN_WARNING "Falling back to a sane timesource
n
ow.\n");

clock_fallback();
}
/* ... but give the TSC a fair chance */
if (lost_count > 25)
cpufreq_delayed_get();

and cpufreq_delayed_get is what prints the message you see. It could be from
many possible sources, not all of them involving fried hardware

< Previous Next >
Follow Ups
References