Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] yast and postfix
  • From: Togan Muftuoglu <toganm@xxxxxxxxxxxx>
  • Date: Sat, 5 Feb 2005 12:53:05 +0100
  • Message-id: <20050205115305.GK2252@xxxxxxxxxxxx>
* Jeffrey Laramie; <suse-linux-e@xxxxxxxxxxxxxx> on 02 Feb, 2005 wrote:
Hi All,

I have a problem with yast re-enabling postfix on it's own. This is on a mail server that runs XMail which has it's own local mail delivery daemon. I have disabled postfix since it's redundant and it binds to the port that XMail needs. However sometimes when I make a change using yast it insists on starting postfix behind my back. Any ideas?

If you want to use XMail then the best would be to uninstall postfix.
However then you would run into the problem of programs needing
smtp_deamon (it is just the cosmetic thing I ould guess as the XMail
will do the job)
So the second thing to do is install a fake_smtp_daemon rpm. Hence
progroms requiring the smtp_deamon will be satisfied and you will be
able to use your XMail with no problem at all.
You can use the attached spec file to build your fake_smtp.rpm just make
sure that it does not conflict with Xmail if it was installed with rpm.

All credits goes to Christopher Mahmood (former Mailadmin of SuSE lists)


--
Togan Muftuoglu |
Unofficial SuSE FAQ Maintainer | Please reply to the list;
http://susefaq.sf.net | Please don't put me in TO/CC.
Nisi defectum, haud refiecendum

# Change below if you want to protect something other
# than qmail. For example, for postfix, put qmail in, but leave
# postfix out. Leaving out the MTA you want to protect, will
# let you install the MTA from an rpm---if that is what you want.
Conflicts: sendmail, postfix
Group: Productivity/Networking/Email/Servers
License: GPL
Name: fake_mta
Provides: smtp_daemon
Release: 1LSB
Summary: fake package to protect my MTA
Version: 1
Buildarch: noarch

%description

A fake package so that foreign MTAs like sendmail will not be
installed on my system (messing up my non-rpm MTA install). For
example, a system upgrade will install sendmail if it thinks you do
not have an MTA/smtpdaemon installed.

%changelog
* Wed Mar 5 2003 Christopher Mahmood <ckm@xxxxxxxx>
- LSB requires smtp_daemon, not smtpdaemon
* Fri Sep 6 2002 Mate Wierdl <mw@xxxxxx>
- First cut

%files

< Previous Next >
References