Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] Apt-get problem
  • From: David Robertson <derobertson@xxxxxxxxxx>
  • Date: Sat, 05 Feb 2005 20:32:37 +0300
  • Message-id: <1107624757.16316.12.camel@xxxxxxxxxxxx>
On Sat, 2005-02-05 at 15:33 +0000, Keith Powell wrote:

--snip--

> However, it is the other part of my apt/synaptic problem which
> is bugging me.
>
> Headings are fine, but I can't download any packages from either repository.
> Anything I try to download fails with an "unknown signature" error message. I
> have even tried to download the rpmkey files (in case that was what was
> causing the problem), but they failed with the same error message. I have
> tried deselecting "verify packages signatures" in synaptic, but it makes no
> difference.
>
> I have tried downloading just your rpmkey file - same error, and also I have
> tried downloading one of your packages (gdome) but that fails also with the
> error message.
>
> So, I went to the GWDG site and manually downloaded both your rpmkey and gdome
> on to my hard drive. Using Konqueror/YasT they have installed without any
> problems. So it is just apt which is the problem.
>
> I have been using the apt/synaptic combination for years, without any
> problems. But it has suddenly gone faulty for some unknown reason. I have
> even uninstalled and reinstalled them, in case they had got corrupt. Still no
> luck.
>
> As a last resort, I may try installing SUSE on a spare hard drive and see if
> it is the same with a new installation. Apart from this, I can't think what
> else to try.

Edit /etc/apt/apt.conf.d/gpg-checker.conf and change "true" to "false"
That may solve your problem although, quite why the problem should
suddenly appear is a mystery.

HTH

David


< Previous Next >
Follow Ups