Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: 9.2 scsi install: no fstab found
  • From: Jim Osborn <jimo@xxxxxxxxxx>
  • Date: Sun, 6 Feb 2005 23:18:07 -0800
  • Message-id: <20050207071807.GA1040@xxxxxxxxxx>
On Sun, Feb 06, 2005 at 4:50:01PM -0500, Carl E. Hartung wrote:
> The CD is fine.

Well, not if you're using a sym53c895 SCSI controller, apparently.


> 1. If you were installing 9.2 on IDE instead of SCSI, you'd have
> made the module diskettes, used them to complete your installation
> and */maybe/* you'd be thinking about why your CD drive isn't
> letting you boot normally off the Linux CD.

If I were using IDE instead of SCSI, I wouldn't be concerned with
the sym53c895 SCSI module at all; the whole issue would be moot.
Fwiw, I made the boot disk set and booted from floppy, just to
eliminate the CD boot as a variable (all previous installs have
been via boot diskette).


> 2. If you were adding this SCSI controller into an already
> functioning 9.2 system, you'd /still/ be forced to deal with
> whatever the firmware / module / config issues are.

Exactly. It seems SuSE 9.2 is contra-indicated for use with
sym53c895 based systems. Perhaps, as another respondent indicated,
the sym53c8xx module works with another SCSI controller that is not the
sym53c895, but as it comes out of the box, SuSE 9.2 does not work
with the sym53c895.


> So, try not to confuse one problem with the other. And please don't
> become prematurely discouraged or disappointed with SuSE *or* Novell
> *or* 9.2. This is a great distribution -- you just have a couple of
> unique 'humps' to overcome.

Notice I didn't say "look for a different distro..." :) I'd like very
much to be able to use it. I am disappointed that a fairly popular
essential piece of hardware, that worked perfectly well under earlier
SuSE distros has ceased to work in 9.2. I can see tripping up over
this issue early on in the distro release process, with all the various
bits of hardware to cover, but when the reports start coming in, I'd
be a lot less disappointed if I saw evidence of a fix or a workaround
emanating from SuSE. Connecting with the hard disk is a pretty
fundamental part of installing a distro, a real show stopper.


> | The images on the CD seem to have a boot sector and a disk full
> | of stuff that's not individual files. Will linuxrc take a module
> | from a normal ext2 diskette?
> <whack>
>
> It just so happens that I've always used rawwrite.exe under Windows
> (Gasp!) to create the floppies. Why? Because the only time I need a
> Linux diskette is when the system that I need it for is down! The rest
> of the time stuff goes in and out of the box via TCP/IP, CDRW, etc,.
> Besides, MS makes a /great/ diskette duplication platform! ;-)

If you've got a spare MS box around. I'm all linux here. :)

But how the diskette is copied is not the question; it's whether the
image can be a simple module sym53c8xx.o, copied to a diskette with
an ext2 filesystem on it and subsequently loaded into the
installation process with linuxrc or whatever.


> Anyway, the first step here is to isolate the exact cause of your
> SCSI adapter problem.

The most relevant threads I was able to find in English were several
bug reports, and an 8-article discussion on alt.os.linux.suse that
seemed to conclude that several posters had problems with the sym53c8xx
module and the 2.6 kernel, whereas all had been well with the 2.4 kernels.
No one had any workarounds to suggest.

searching:
site:suse.com sym53c8xx "9.2"
gives 4 results, all in German.

Some other search recipes give other German results, and one in
Russian, if I'm not mistaken. Unfortunately, my language skills
extend only to English.


> You may have to update the controller bios...

Really? Would a newer kernel or driver require a bios upgrade? Are
there even Linux tools to do that? That seems like a very hostile
feature, that most driver maintainers would take pains to avoid.


> or pass some parameters to the module before it loads... or, or,
> or. It's all conjecture at this point. If you'd like, get some of
> this research done and holler back.

Some posters referred to above said they'd tried various parameters,
all to no avail. They didn't say just what parameters they'd tried.
One poster mentioned the prospect of different interrupt handling
in the 2.6 kernel being a potential problem. There was considerable
discussion of various patching strategies for the sym53c8xx for use
in a pcmcia environment.

There may well be a workaround, possibly involving compiling a patched
kernel, or a patched sym53c8xx module. If that's the case, I'd think
SuSE might want to put up the results for offer on their site.

The simplest workaround would be to offer installers the choice of
falling back to the 2.4 kernel series, which seems to work splendidly.
If moving to the 2.6 series renders the distro un-installable, maybe
the 2.4 kernel would be the way to go.

I can't think of anything else to research. If anyone from SuSE
is following this thread, it'd be nice to know where someone in my
position stands. I'd hate to waste a couple hundred hours chasing
a dead end, which is what 9.2 looks like at this point.

Does anyone have any other suggestions?

One more procedural question: since the kernel messages are obviously
stored somewhere by linuxrc and yast, it seems I should be able to
copy them to a floppy before abandoning the installation. Does anyone
know where they're stored? Has anyone saved those messages this way?
If I persue this on the newsgroups, it'd be nice to be able to share
the error messages I see; they're way too extensive, in way too tiny
type for me to copy by hand.

Jim

< Previous Next >