Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] Help to install Firefox and Flashplayer 7 [Solved]
  • From: Catimimi <catimimi@xxxxxxxxxxxxxx>
  • Date: Tue, 08 Feb 2005 12:23:31 +0100
  • Message-id: <4208A133.4090008@xxxxxxxxxxxxxx>
Carl E. Hartung a écrit :

Hi Michel,

Catimimi wrote:
| Thanks for all your replies, I made a lot of trials and below are the
| results
| and comments :

You're welcome and thanks for the feedback!

|> ...I want(ed) Firefox and Thunderbird for their possibilities
|> of extension : for instance RSS

You are wandering closer to the bleeding edge than I usually go! :-)

|> Thanks for the RPM, I found too the one for Thunderbird, I installed
them,
|> For Firefox, no problem, it works but with warnings about write
|> permissions,

?? Obviously something is very wrong here. ??

|> if I install the Firefox.tar.gz in my home directory, I've no warnings !
|> Certainly it doesn't matter.
|> For Thunderbird I get a segmentation fault with the RPM and with the
|> tar.gz !! So no Thunderbird and no RSS without addon software.
...
Could these problems be due to you mixing and matching tarball & rpm
packages? Are you installing the tarballs as root? (hope not) Also, I'd
like to know how you are installing rpms as user and not root? Or have
I misinterpreted you?
...
|> Thanks, I tried that, the flash RPM ... but no flash working with firefox
|> It works very well with Mozilla 1.7
|> So no Firefox, I'm back to the Mozilla suite !!!
...
|> I don't know where are my errors, what lib could be missing. I don't
|> understand but being a searcher I'm not satisfied.
...
I think you should consider starting with a "clean" SuSE 9.2
installation. I do not experience the problems you have with
permissions and segmentation faults. Can you "back out" these
procedures and restore to original settings?

Also, you should not have to "micromanage" the libraries on your system
- -- unless, of course, you are a programmer. In this case, you should
know what you're doing better than me.

For the plugins, here is the unedited listing of my MozillaFirefox
1.0-6.1 plugins directory. Maybe your permissions need to be set the
same? These are as the installers have put them, not inadvertantly
mangled by my fingers ;-)

lrwxrwxrwx 1 root root 40 2005-01-14 18:11 flashplayer.xpt ->
/usr/lib/browser-plugins/flashplayer.xpt

lrwxrwxrwx 1 root root 42 2005-01-14 18:11 libflashplayer.so ->
/usr/lib/browser-plugins/libflashplayer.so

lrwxrwxrwx 1 root root 85 2005-01-14 18:11 libjavaplugin_oji.so ->
/usr/lib/jvm/java-1.4.2-sun-1.4.2.06/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so

lrwxrwxrwx 1 root root 45 2005-01-16 23:42 libmozilla_bonobo.so ->
/usr/lib/browser-plugins/libmozilla_bonobo.so

lrwxrwxrwx 1 root root 39 2005-02-01 12:52 libnptcl3.0.so ->
/usr/lib/browser-plugins/libnptcl3.0.so

- -rwxr-xr-x 1 root root 17316 2005-01-24 09:53 libnullplugin.so

lrwxrwxrwx 1 root root 42 2005-01-14 23:54 mplayerplug-in.so ->
/usr/lib/browser-plugins/mplayerplug-in.so

lrwxrwxrwx 1 root root 35 2005-01-14 18:11 nphelix.so ->
/usr/lib/browser-plugins/nphelix.so

lrwxrwxrwx 1 root root 36 2005-01-14 18:11 nphelix.xpt ->
/usr/lib/browser-plugins/nphelix.xpt

lrwxrwxrwx 1 root root 52 2005-01-28 18:30 nppdf.so ->
/usr/X11R6/lib/Acrobat5/Browsers/intellinux/nppdf.so

lrwxrwxrwx 1 root root 36 2005-01-14 18:11 nsdejavu.so ->
/usr/lib/browser-plugins/nsdejavu.so

I still haven't followed up on your fonts question (the "urw-fonts"
anyway) -- any luck with Google?

regards,

- - Carl

Hi Carl,

After a lot of trials, I succeed with Firefox and Thunderbird.

First I've to tell you that I use to manage RPMs and tarballs and that I have no
permissions problems. Very often I use tarballs when no RPM is available, and
I like to choose my compilations options.

So I used the French Firefox tarball, not the SuSE rpm, because I have better to speak French !
If I install it (as root) in a folder where I don't have (as user) the write permission, I get
the same warnings that with the RPM (!) but it works. If I link the libraries as you told me
and if I add my path ( I choosed /usr/local/firefox) in /etc/ld.so.conf and run ldconfig,
I'm able to use the plugins.

Same I copied (no install needed) French Thunderbird in folder /usr/local/thunderbird, add the path
in /etc/ld.so.conf and run ldconfig as root (absolutely necessary or thunderbird doesn't find the
libraries, I have no "segmentation fault", but if I accept to import the mozilla mail and parameters
Thunderbird crashes !! So I'd to recreate all my mail RSS and news accounts !

In fine, now I'm able to share Thunderbird folders with native Windows XP or with Windows XP guest
with VMware and my mail RSS and news are always synchronized.

Thanks again for your help.

Michel.





< Previous Next >
This Thread