Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] Postfix problems in 9.2
  • From: David Robertson <derobertson@xxxxxxxxxx>
  • Date: Wed, 09 Feb 2005 19:30:54 +0300
  • Message-id: <1107966654.16410.3.camel@xxxxxxxxxxxx>
On Wed, 2005-02-09 at 08:12 +0100, Per Jessen wrote:
> David Robertson wrote:
>
> > Just took the plunge and did an ftp installation of 9.2 on my latop, an HP zd7000. This
> > connects to the internet via broadcomm wireless (using driverloader) and a D-Link wireless
> > adsl router. There is no apparent problem with the network connection. I have set up fetchmail
> > to collect my pop3 mail and forward it via procmail but it is not reaching me. My mail log
> > shows:
> >
> > "fatal: config variable inet_interfaces: host not found: ::1"
>
> ::1 is your localhost in IPV6 just as 127.0.0.1 is localhost in IPV4.
>
> > Looking at /etc/postfix/main.cf, I found:
> > "inet_interfaces = 127.0.0.1 ::1"
>
> postfix doesn't have IPV6 support before 2.2 - maybe check your version?
> Or maybe you need to enable IPV6 support (only ipv4 is enabled by default):
>
> inet_protocols = ipv4, ipv6
>
> > and after googling I changed this to:
> > "inet_interfaces = all"
> > but with no change.
>
> So you still get "fatal: config variable inet_interfaces: host not found: ::1" ??
>
> That would seem to suggest that postfix is reading a different config file, not the one you
> changed.
Yes - I still got that error, but I think it was the ipv6/version
support issue. I was running 2.2, having updated via apt. I have now
downgraded to 2.1.5-3.3 and all is well. Thanks for your help.

David


< Previous Next >