Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] Kate where is the run script located
  • From: devosc <devosc@xxxxxxxxx>
  • Date: Sun, 13 Feb 2005 10:48:55 -0600
  • Message-id: <da0b703b0502130848841a23b@xxxxxxxxxxxxxx>
I used to be able to... only noticeable difference between now and
previously, is that from the SuSE Menu I can actually lauch YaST, i.e.
the Gnome Destop/Window Manager is loading YaST via gnomesu...
previously when I was able to launch Kate via a root launched instance
of knonqueror, I would have to open YaST via kdesu /sbin/yast2.

I frequently have to edit files that are root privileged only and so
locating and launching kate via konqueror is quite effcient (I have to
enter the root password in order to launch these apps).

Incidentally, I was able to locate kate, /opt/kde3/bin/kate, and was
able to create (copy over) a kate.desktop entry so that it now appears
in (Gnome) SuSE Menu :: Utilities :: Editor list...

I even tried to create a symlink, but I got a message probably related
to what you mentioned... I think what you said is understandable, but
its just that I'm so used to of been able to doing it that way...

G.


On Sun, 13 Feb 2005 08:30:00 -0800, Scott Leighton <helphand@xxxxxxxxxxx> wrote:
> On Sunday 13 February 2005 8:07 am, devosc wrote:
> > the problem is that I'm using Gnome as my Display and Windows Manager,
> > this causes Kate to not appear in the SuSE Menu :: Utilities ::
> > Editor, consequently in the shell when I su to root and run 'kate' it
> > says command not found, but if I did so as a normal user it will run.
> >
>
> That has nothing to do with Gnome, same happens with KDE,
> someone more knowledgable can explain it, but I believe it is
> intentional, root shouldn't normally be running those apps.
>
> > The reason why I'm asking is that I still use Konqueror as the file
> > manager, and I run it as root 'kdesu kfmclient openProfile
> > filemanagement' but then when I try to open a file with Kate nothing
> > happens (probably because of the command not found error seen via the
> > shell).
>
> You might want to ask yourself why you need to do that from
> root.
>
> Scott
>
> --
> POPFile, the OpenSource EMail Classifier
> http://popfile.sourceforge.net/
> Linux 2.6.8-24.11-default x86_64
>
> --
> Check the headers for your unsubscription address
> For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
> Also check the archives at http://lists.suse.com
> Please read the FAQs: suse-linux-e-faq@xxxxxxxx
>
>


--
devosc

< Previous Next >
Follow Ups