Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] Cannot upgrade to 9.2
  • From: Ralph Sanford <rsanford@xxxxxxxxxxxxxxx>
  • Date: Tue, 15 Feb 2005 20:48:40 -0700
  • Message-id: <1108525721.7941.19.camel@xxxxxxxxxxxxxx>
On Tue, 2005-02-15 at 16:32 -0800, Marc Chamberlin wrote:
> Hello -
>
> I have SuSE 9.1 running on my desktop and am trying to upgrade to SuSE
> 9.2 unsuccessfully. My desktop is configured with 2 disk drives, the
> first drive and part of the second have a number of partitions which
> are used by Windows XP, and the second drive has two partitions for
> Linux, one for the swap and one for the rest. Approx 70gbytes are
> available for Linux.
>
> When I attempt to upgrade, during the automatic installation, I reach
> the point where YAST2 asks me what language I am using and I accept the
> selection for English. Shortly after that point I get a red box with an
> very UNHELPFUL error message - "An Error occurred during the
> installation" At which point I cannot proceed any further as the
> computer/mouse/keyboard is completely hung.
>
> Attempting to use the manual mode gets me a little bit more info... I
> get beyond the language settings, am asked to confirm driver activation
> settings for my Adaptec 29160 Ultra160 SCSI card (aic7xzxx), the hard
> disk controller, DM DM-MOD, DM-Snapshot at which point I got an error
> message about the partitioning for /dev/hda is not readable by "parted"
> My understanding is since my first disk drive is being used by Windows,
> this is ok and understandable and I simply click on OK to accept this
> fact and tell the installation to proceed. At this point I get the red
> dialog box telling me "An error occurred during the installation" and
> the computer again hangs and cannot proceed any further.
>
> I do not think the partition tables are in error since both Windows and
> SuSE9.1 work fine, but I got a suspicion that SuSE9.2 is not handling
> the partitioning configuration properly and getting confused about it.
>
> Does anyone have any suggestions as to how I should proceed?
>
> Sincerely yours.... Marc Chamberlin...
>

Marc,

Two quick guesses:

1. Have you tried installing with the acpi setting on or off? With
earlier versions of SuSE it seemed to help with many installations if
the initial setting was acpi "off". With SuSE 9.2 the acpi "on" setting
appears to be the better option. (Even with my laptop that does not
support acpi, if the installation was set to acpi "off" then the
installation was incredibly slow to the point of being non-functional.
It was much better to install with acpi "on" and then reconfigure later
to turn off acpi and add apm.)

2. Have you tried "manual installation"? This would give you the chance
to confirm modules and will sometimes workaround hardware issues on the
installation.

HTH


< Previous Next >
Follow Ups
References