Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Mounting,Unmounting USB devices
  • From: "Dennis J. Tuchler" <dennis.tuchler@xxxxxxxxxxxxx>
  • Date: Sat, 19 Feb 2005 16:07:45 -0600
  • Message-id: <200502191607.45784.dennis.tuchler@xxxxxxxxxxxxx>
I have a Dell laptop attached to a monitor, printer, etc, by a port
replicator. The docking device has a USB port in its side, making mounting
and unmounting USB devices quite easy. My problem has to do with changing
USB devices at the same USB port. How do I do it, without rebooting. Here's
the story from which this question came up:

I plugged a USB device into the USB port, and after several tries, the device
registered at the appropriate directory, but seemed empty. I tried another
USB device and tried to read that and found nothing (there is a great deal of
stuff on that device). As root, I unmounted the device, and then plugged the
other one in. Nothing. I saw what looked like an entry for that device at
the /media directory, but ls revealed nothing. After rebooting the computer
and then plugging in the second USB device, I finally found the files on it
and could work with one of them.

Is there an easier way?

dj tuchler

< Previous Next >
This Thread
  • No further messages