Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] Firefox can't open display
  • From: Chris Carlen <crobc@xxxxxxxxxxxxx>
  • Date: Sat, 19 Feb 2005 19:06:37 -0800
  • Message-id: <4217FEBD.8070609@xxxxxxxxxxxxx>
Patrick Shanahan wrote:
* Chris Carlen <crobc@xxxxxxxxxxxxx> [02-19-05 21:17]:

I tried installing Firefox 1.0 on two Suse 9.1 machines. They have different updates applied. One machine complained while installing, the other complains when the user tries to run.

# Xlib: connection to ":0.0" refused by server
Xlib: XDM authorization key matches an existing client!

(firefox-bin:5441): Gtk-WARNING **: cannot open display:


You are trying to start an X app as root. Try to start it as <user>.


First, to install the program into a system path, one must be root. The installer is a GUI program, thus must be run as root.

Furthermore, Firefox demands to be started as root the first time, so it can set up some files in its install path. Then you can run it as a user.

I have had incidences of the *installer* giving the above error, and the application giving the error under the three conditions:

1. root starts installer
2. root starts app
3. user starts app

Which one happens when is inconsistent and irreproducable. One one machine, the user can never start the app, though root was able to install. On another machine the results were different. Some errors installing, user entered

xhost +localhost

Then it worked. But this doesn't work on the other machine.



--
_____________________
Christopher R. Carlen
crobc@xxxxxxxxxxxxx
SuSE 9.1 Linux 2.6.5

< Previous Next >