Mailinglist Archive: opensuse (2912 mails)

< Previous Next >
Re: [SLE] Firefox X display problem--Start Again
  • From: Catimimi <catimimi@xxxxxxxxxxxxxx>
  • Date: Tue, 22 Feb 2005 13:32:50 +0100
  • Message-id: <421B2672.4090906@xxxxxxxxxxxxxx>
Chris Carlen a écrit :

Anders Johansson wrote:

On Monday 21 February 2005 02:29, Chris Carlen wrote:

anok@ting:~> Xlib: connection to ":0.0" refused by server
Xlib: XDM authorization key matches an existing client!
(firefox-bin:5671): Gtk-WARNING **: cannot open display:



"XDM authorization key matches an existing client" doesn't mean "you are not authorized". This is an old problem and it has nothing to do with running as root, so sux or kdesu won't help

Here's what you need to do: first turn off x authentication completely with "xhost +" (run as your regular user). Then run firefox once and let it start up, then close it down and re-enable x authentication with "xhost -" (again, run as your regular user). After that, things should work again as normal


Thanks for the input.

Unfortunately, it doesn't work.

Here is what I tried this time:

As root, deleted the entire contents of the /opt/firefox install dir.
As user, deleted the ~/.mozilla/firefox dir; then log out of X
As root, deleted the entire contents of /tmp
As root, reinstalled Firefox anew. It ran fine, and loaded the application automatically after installing. Closed it and then...
As user, ran command:

> xhost +

As user, ran firefox

Same results. Repeating infinite loop of error messages as shown in my OP, taking about 5 minutes to reach segfault.

Then I suspected maybe something was going bonkers related to my wife's international settings in her KDE setup. I logged into my account which has KDE in its virgin state since I don't normally use her 'puter. Same results.

The plot thickens:

I ran firefox as root. It worked, in the user's X session. Then I tried to run firefox as user with the root instance of Fx still running. The user's Fx then worked! Closing the root Fx, and trying to start Fx again as user fails.

Now things get wierder still. When I type a URL in either root's or the user's Fx window, the URL appears in the history list of BOTH windows. Thus, URLs entered as root appear in the history of the user's window and vice versa.

This is completely bonkers. I have never seen such silliness before.


Any ideas what is going on?


Thanks.

Hello,

I didn't want to interfere earlier in your discussion, but as you seem to be lost, I can try to help you with firefox and thunderbird which are now working
very well in my box with SuSE 9.2 pro.
If you look in this list about 2 or three weeks ago, you'll have the history of my difficulties.

I tried to install the rpms for SuSE 9.2 and I got the same difficulties than you ! :-(
So I came back to firefox and thunderbird installers, during the installation process, you can read that "you have to install in a folder where you have writing permissions" !! It is not the case for the folder /opt/firefox or /opt/thunderbird !! =-O so I installed in my home folder and i no longer got error messages !! :-)

BUT, while starting thunderbird, the windows stops to open and as you I got segmentation faults !! :-!

I was desperated when I tried once more, and to go faster, decided not to import from previous applications AND :-) everything ran fine except that I'd to
manually configure the application. 8-)

So I hope that you can share my experiments.

Michel.







< Previous Next >
Follow Ups