Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Windows No Longer Boots Following the Installation of SUSE LINUX 9.1
  • From: Tim Taphorn <ttaphorn@xxxxxxxx>
  • Date: Mon, 31 May 2004 15:07:39 -0700
  • Message-id: <40BBACAB.1000904@xxxxxxxx>
Hi,

I'm looking for help repairing partition damage that occurred when I installed SuSE 9.1 Pro. I'm not altogether ignorant of Linux , but I'd still classify myself as a beginner. I wouldn't want to recompile a kernel on *my* machine.

I received my order of 9.1 Professional in early May and installed it on my Thinkpad T30, which came with Win2K Pro. I have worked in software testing and documentation for about 12 years now, and frequently work on a contract basis. Although I have to have Windows to work with my clients, I rarely used MS-made applications for anything other than documentation (Excel spreadsheets, Word documents). Mostly I've worked with OpenOffice, Mozilla, Thunderbird, and others for my personal work. But I must have Windows for some of my computing needs.

When I installed 9.1, I lost access to the Windows OS. Due to the magic of Linux and OpenOffice, I can still see and open files on the Windows partition (minus a lot of formatting, formulae, etc.). However, I'd like to get back to a dual boot. (I've had RedHat on this machine in the past, and it handled the partitioning just fine.) I've made regular checks at the SuSE web site looking for a fix, and it arrived a few days ago. http://portal.suse.com/sdb/en/2004/05/fhassel_windows_not_booting91.html

I downloaded parted.iso.gz, unzipped it, burned it to a CD, and followed the instructions on SuSE's web site (missing a step, but I muddled through). I got as far as the step saying "The following dialog for repairing the partition table displays your hard disk (usually /dev/hda) and the status of the partition table (broken). Select the hard disk and click "OK" in order to repair the partition table."

I clicked OK and got the following message panel:
>>>>>>>>>>>>>>>>>>>>>>>>
hda: 40.0 GB, CHS 71520/16/63
FAT/NTFS partitions suggest these CHC values:
/dev/hda1: fat 32, CHS 77520/16/63
/dev/hda2: fat 32, CHS 5168/240/63
Warning: FAT/NTFS partitions with differing values
Warning: Accessing these partitions from Windows might fail due to a disk geometry mismatch: /dev/hda2

Would you like me to try and fix the partition table?
>>>>>>>>>>>>>>>>>>>>>>>>

I click 'Yes', and the next thing I get is the dialog panel from the previous step (hard disk status broken) asking me to select the hard disk and click 'OK' to repair the partition table. I can loop between these two actions, or I can just reboot into SuSE. But I can't get the parition table repaired.

Has anyone successfully repaired their partition after having this problem with SuSE and dual booting? And does anyone know if this is a rare event with this release? It seems that if it had been discovered by SuSE when they were testing, they'd have shipped the product with a warning.

Thanks,
Tim

P.S. By the way, with the exception of this partition problem and the DVD's not working, everything else works just fine for my needs. The installation found all my hardware, and I was downloading updates from SuSE within minutes of completing the install.


< Previous Next >