Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
service that won't start in 9.1
  • From: John Pettigrew <john@xxxxxxxxxxxxxxxx>
  • Date: Fri, 28 May 2004 10:12:41 +0100
  • Message-id: <gemini.hyf2x500dae8006dm@xxxxxxxxxxxxxxxx>
I have a script that starts fetchmail the way I want it, which lives at
/etc/init.d/fetchmail. In previous versions of SuSE (previously, I was on
8.2), this has worked with no problem. However, since changing to 9.1, I've
had great problems with it. First, SUSE keeps replacing it with its own
fetchmail script - this problem, I solved by removing write permissions to the
script! Second, it refuses to start it at boot time. I have several times used
the runlevel editor in YaST to set it to run at levels 3 and 5, and started it
from there (after which it runs). However, each time I reboot the box, it
fails to get started. The runlevel editor after a boot shows that it's not
running (in expert mode - Simple mode reports that it *is* running!).

Any ideas what's going on here?

John
--
John Pettigrew Headstrong Games
john@xxxxxxxxxxxxxxxxxxxxxx Fun : Strategy : Price
http://www.headstrong-games.co.uk/ Board games that won't break the bank
Knossos: escape the ever-changing labyrinth before the Minotaur catches you!

< Previous Next >
Follow Ups