Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
[SOLVED] VMware / SuSE 9.1 USB problems
  • From: burgeke@xxxxxxxxxxxxxxxxxxxxxx
  • Date: Wed, 26 May 2004 08:35:40 -0400
  • Message-id: <20040526123547.87463620157@xxxxxxxxxxxxxx>
Earlier threads discussed the fact that USB devices would not work within
VMware running under a SuSE 9.1 host OS. This was due to the fact that
/proc/bus/usb/devices was renamed to devices_use-sysfs-instead which
apparently is a SuSE hack (does not exist in the pristine kernel.)

At any rate, thanks to Craig Altenburg on this list I was able to modify
inode.c and rebuild the usbcore module naming the file back to "devices". It
works perfectly but my only concern was that I was breaking something within
SuSE. I filed a support request with SuSE. However, this was out of the
scope of my free install support.

Petr from the VMware list proposed the following fix within VMware which
worked perfectly. (Thanks Petr!)

mkdir /tmp/usb
(cd /proc/bus/usb; for a in *; do ln -s /proc/bus/usb/$a /tmp/usb/$a; done)
ln -s /proc/bus/usb/devices_please-use-sysfs-instead /tmp/usb/devices

Then modify the .vmx file for your VM and add the line:

usb.generic.devfsPath = "/tmp/usb"

Hope this helps someone..

Keith

< Previous Next >