Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] Installing fonts in 9.1 breaks gimp & causes font problems in gnome apps
  • From: BandiPat <penguin0601@xxxxxxxxxxxxx>
  • Date: Tue, 25 May 2004 23:12:36 -0400
  • Message-id: <200405252312.36669.penguin0601@xxxxxxxxxxxxx>
On Tuesday 25 May 2004 10:44 pm, Mark A. Taff wrote:
> Hi all! Hope someone can help me.
>
> I'm having problems with fonts on 9.1 Pro. The problems occur on all
> 3 machines I have running 9.1. It worked fine under 9.0 w/kde3.2, so
> it must be something new.
>
> Basically, installing extra true type fonts causes the following
> errors:
>
> Gimp-2.0 starts to run, then crashes. Running from a console gives
> error: Gimp-Text-ERROR **: file gimpfontlist.c: line 235
> (gimp_font_list_font_desc_from_pattern): assertion failed: (res ==
> FcResultMatch)
>
> Running it with the -f flag, it starts and runs fine (bypassing the
> error). However, then the fonts look just like in other gnome apps.
>
> GKrellm uses nice fonts for the krells, but the config dialogs have
> the ugly fonts. e2k-gui is also affected.
>
> Generally, certain characters seem bolded, like all caps and lc chars
> 'vywax'
>
> I've tried everything I can think of to fix it. The only thing that
> works is deleting the newly installed fonts, then running
> `fonts-config -f`
>
> I am installing 522 more true-type fonts (38.6MB) for a total of ~980
> true-type fonts.
[..]
> Regards,
> Mark
**********

Mark,
Could you be overloading Gimp with fonts? Try adding just a few, then a
few more to possibly see where it breaks. That would be my first
thoughts, just too many fonts for the system to deal with. You can
also put fonts in the Gimp directory for it's use only. There was
mention of that on the Gimp list today.

Later,
Lee
--
--- KMail v1.6.2 --- SuSE Linux Pro v9.0 ---
Registered Linux User #225206
On any other day, that might seem strange...

< Previous Next >
Follow Ups
References