Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] Configuring a systems time - which files to edit? - SOLVED
  • From: "Hylton Conacher (ZR1HPC)" <hylton@xxxxxxxxxxxx>
  • Date: Mon, 24 May 2004 12:19:07 +0200
  • Message-id: <40B1CC1B.7050206@xxxxxxxxxxxx>
Hylton Conacher (ZR1HPC) wrote:
I am having a problem with my SuSE 9.0 PRO only box in that it seems to lose time. considering the machine is only 1 year old I hope it is not the CMOS battery. To rule this out entirely I would like to check the configuration files of the KDE time display. The system seems to lose approx 10 minutes each time I reboot it. What I cannot understand is that on booting linux has to get the time from the CMOS, even if it never consults it again. On a shutdown the system time and hardware time are synchronised and I think this is where the error is creeping in. so therefore for the clock to be wrong linux must not be keeping time incorrectly as each time it syncs the software and hardware time it compounds the error ie adds more of an error each time it is shutdown.

I have already been to Yast and checked the time there and to see if there where any other options but alas none. I have right clicked on the time, entered the root pwd and edited the time and confirmed my time zone, and still not seen any other options available.

Is there perhaps a clock setting that adds minutes to cater for time corrections or something that might be enabled? Where can I find the files I need to browse and possibly edit, and what are they called?

Help would be much appreciated to rule linux out as the faulty party
Thanks to both pinto and Carlos for the /etc/adjtime suggestion. I have deleted it and the time has maintained itself since your reply.

Thanks again
Hylton Conacher - Licenced Windows user
Registered Linux user # 229959 at
Currently using SuSE 9.0 Professional with KDE 3.1

< Previous Next >